[Spacewalk-list] Package update weirdness

David Nutter davidn at bioss.sari.ac.uk
Fri May 21 09:06:05 UTC 2010

On Fri, May 21, 2010 at 05:24:18PM +1000, McLeod, Matt wrote:
> I'm running 0.8 on CentOS 5.4 with Oracle XE.  The database doesn't seem
> to have maxed out yet (it's at ~3.3GB) and I'm not getting anything that
> looks like an error message.
> Ever since the daily spacewalk-sync cron job updated the CentOS 5 base
> channels to 5.5 I've been seeing unexpected behavior with respect to
> package upgrades.  The SW web interface shows rather fewer than expected
> packages needing upgrade (~20 on most hosts) and "yum update" on the
> hosts show no packages needing upgrade.
> If I unsubscribe a client from all its channels then resubscribe the
> numbers look more reasonable -- 113 on the one I tested -- but "yum
> update" still doesn't think there's anything to upgrade.
> I've tried forcing the issue with yum ("yum clean all", "yum
> check-update") but it makes no difference.
> I've tried scheduling the updates via the web interface then doing a
> forced checkin ("rhn_check"), likewise no updates are applied.
> Finally, I've tried deleting the client from SW and then force
> re-registering.  Same result.
> I'm not sure where to go from here.  Does anyone have any suggestions?

It sounds like Taskomatic is not rebuilding the repository
metadata. Check your taskomatic logs in /var/log/rhn and also check
that the package cobbler-web is not installed as I believe that was
causing problems for others on the list. 

You can force an update of repository metadata by deleting the files
in /var/cache/rhn/repodata/.


David Nutter  				Tel: +44 (0)131 650 4888
BioSS, JCMB, King's Buildings, Mayfield Rd, EH9 3JZ. Scotland, UK 

Biomathematics and Statistics Scotland (BioSS) is formally part of The
Scottish Crop Research Institute (SCRI), a registered Scottish charity
No. SC006662

More information about the Spacewalk-list mailing list