[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Spacewalk-list] Task Schedules not running automatically



Try 'service taskomatic restart' and then watch /var/log/rhn/rhn_taskomatic_deamon.log to see if there are errors reported. Also make sure that there aren't weird firewall rules or something that would prevent tomcat from calling in to taskomatic's api.

-Stephen

On 02/04/2015 01:26 PM, Jagga Soorma wrote:
Everything seems to be running fine:

# rhn-satellite status
router (pid 2851) is running...
sm (pid 2861) is running...
c2s (pid 2871) is running...
s2s (pid 2881) is running...
tomcat6 (pid 1915) is running...                           [  OK  ]
httpd (pid  1976) is running...
osa-dispatcher (pid  2898) is running...
rhn-search is running (2139).
cobblerd (pid 8187) is running...
RHN Taskomatic is running (19902).

One thing to point out is that I am using a external postgres db.  Not
sure if that is causing any issues here?  Not sure what else to check
but things look good from a configuration/service perspective.  What
am I missing here?

Thanks!

On Wed, Feb 4, 2015 at 10:15 AM, Jagga Soorma <jagga13 gmail com> wrote:
More information, when I click on "Edit Schedule" for that task I get
the following message:

"The scheduling service appears down. Please contact your Satellite
administrator"

The taskomatic service is running:
# /etc/init.d/taskomatic status
RHN Taskomatic is running (19902).

And I see the following message in the rhn_taskomatic.log file:

INFO   | jvm 1    | 2015/02/04 10:13:32 | 2015-02-04 10:13:32,639
[Thread-19] WARN  com.redhat.rhn.taskomatic.TaskoQuartzHelper - Job
channel-repodata-default failed to schedule.

Any ideas what I might be missing?

Thanks

On Wed, Feb 4, 2015 at 10:14 AM, Jagga Soorma <jagga13 gmail com> wrote:
More information, when I click on "Edit Schedule" for that task I get
the following message:

"The scheduling service appears down. Please contact your Satellite
administrator"

The taskomatic service is running:


On Wed, Feb 4, 2015 at 10:08 AM, Jagga Soorma <jagga13 gmail com> wrote:
Hi All,

I have recently deployed spacewalk and just noticed that after
uploading new packages the repodata is not being created.  I have to
manually go into "Admin->Task Schedules" in spacewalk ui and click on
channel-repodata-bunch in order for it to work.  After the manual run
everything updates fine and the client starts seeing the new rpm
versions.  I have made sure that the taskomatic service is running and
even tried restarting it without any luck.  I also see the following
schedule that is enabled:

channel-repodata-default 0 * * * * ? 2014-09-17 18:04:36 PDT
channel-repodata-bunch

Am I missing a quartz package or something?  Do I need to do something
to make sure these tasks run automatically on a scheduled time?  I am
using spacewalk version 2.2 and here is the quartz package I have
installed:

# rpm -qa | grep -i quartz
quartz-1.8.4-5.el6.noarch

Any help would be appreciated.

Thanks!

_______________________________________________
Spacewalk-list mailing list
Spacewalk-list redhat com
https://www.redhat.com/mailman/listinfo/spacewalk-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]