[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Spacewalk-list] [2.1 + postgresql] Recover 'kickstart' section



Hello,

Been lurking for years now, as I haven't been messing around in Spacewalk since 2010 (1.4 version) and only last year started again with 2.1. It's a dream to work with postgresql as back-end instead of Oracle.

While I was installing 2.2 on SL 7 and got a bit stuck (encoding, just had time to take a dive and got it working) I tried to setup a kickstarting environment for CentOS 6, SL6 and openSUSE 13. It worked nicely for the CentOS and SL environment, but openSUSE didn't want to install. Not to surprising, as it was fed a kickstart file instead of an autoyast. While I was correcting this the server died on me.

On recovery I can do anything with the environment, even install systems, but when I want to view a list of kickstart profiles or edit a kickstart distribution, I get an internal server error. The summary and the list of distributions is correct, but when I want to edit, nada. Looks like a damaged table with that info, but I can't imagine why you can access the data for install, but not to edit.

Checked rhn, httpd and tomcat logs, quiet as a mouse. I would say the content of the page is incorrect, even though the mouse-over shows the link it should open. Is there any way to get the environment to tell me what it's doing or at least what it's waiting for? (max debug level would be nice)

The 2.1 environment is going to be ditched, so if I break anything else, I don't mind, as I'm already rebuilding, but I would love to get this sorted out. (for when the environment is less expendable)

---

Jan Huijsmans              huysmans koffie nu

... cannot activate /dev/brain, no response from main coffee server


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]