[Spacewalk-list] Upgrading 2.6 to 2.7 - package errors

Rusch, Andy Andy.Rusch at agilysys.com
Tue Dec 26 19:54:27 UTC 2017

I am following the upgrade procedure (I am on CentOS 7.4) and I get the following after # yum upgrade (I have removed the jpackage repo per instructions and all that good stuff.)

Error: Package: cglib-2.1.3-4.jpp5.noarch (@jpackage-generic)
           Requires: asm >= 1.5.3
           Removing: asm-1.5.3-7.jpp5.noarch (@jpackage-generic)
               asm = 1.5.3-7.jpp5
           Obsoleted By: spacewalk-java-2.7.116-1.el7.noarch (spacewalk)
               Not found
Error: Package: google-guice-3.1.3-9.el7.noarch (base)
           Requires: mvn(cglib:cglib)

I tried:

# yum upgrade --skip-broken

Transaction check error:
  file /usr/share/java/commons-validator.jar from install of apache-commons-validator-1.5.0-2.sw.noarch conflicts with file from package spacewalk-jpp-workaround-2.3.5-1.el7.noarch

Error Summary

Any advice/things to try?

Thanks in advance for your input

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/spacewalk-list/attachments/20171226/4a07c09d/attachment.htm>

More information about the Spacewalk-list mailing list