[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

tux freezing



I've got tux running on a dual-cpu, 1G RAM i386 redhat 7.2 box.  I built
the kernel from source, 2.4.18, and grabbed the latest version of tux
(tux2-full-2.4.18-final-A3 and tux-2.2.7).  Otherwise, the box is pretty
standard.

I'm running tux w/ virtual servers enabled (level "1").  I applied the
following config/kernel settings:

echo 50000 > /proc/sys/net/tux/max_connect
echo 8192 > /proc/sys/net/tux/max_backlog
echo "http://192.168.2.128:80"; > /proc/net/tux/0/listen/0
echo "http://192.168.2.128:80"; > /proc/net/tux/1/listen/0
echo 0 > /proc/sys/net/ipv4/tcp_timestamps
echo 2000000 > /proc/sys/net/ipv4/tcp_max_tw_buckets
echo "30000000 30000000 30000000" > /proc/sys/net/ipv4/tcp_rmem
echo "30000000 30000000 30000000" > /proc/sys/net/ipv4/tcp_wmem
echo "30000000 30000000 30000000" > /proc/sys/net/ipv4/tcp_mem
echo 10000 > /proc/sys/net/core/hot_list_length
echo 10000000 > /proc/sys/net/core/rmem_max
echo 10000000 > /proc/sys/net/core/rmem_default
echo 10000000 > /proc/sys/net/core/wmem_max
echo 10000000 > /proc/sys/net/core/wmem_default
echo 10000000 > /proc/sys/net/core/optmem_max
echo 300000 > /proc/sys/net/core/netdev_max_backlog


Most of them are purely out of the various online guides that I culled
together from the dell guide to tux configuration and also the
configuration guides from the specweb99 benchmarks of tux.

Anyways, I'm serving purely static content on this box - all images.  I
put it into production, and it was working really well, serving the
images ridiculously quickly, but I came back in this morning and it was
frozen.  Fortunately it's in a cluster with 2 apache boxes, so they
stayed up, but I'm not sure what to do now.

Tux is frozen w/ ~9000 open connections (it thinks).  I suspended it in
the load balancer, so it's no longer receiving requests, and the load
balancer shows 0 open connections to it, but it's still thinking it has
them open:

# netstat -nap | grep 192.168.2.128:80 | wc -l
   9184

I tried to shut down tux, but it froze.  It's been trying to stop for
hours:

[root@cc128 root]# ps -ef | grep tux
root      4716     1  0 10:55 pts/1    00:00:00 /usr/sbin/tux --stop

[root@cc128 root]# date
Thu Jun 13 15:03:12 EDT 2002

I tried kill -9'ing some of the procs for kicks... but I've got doubts
there.  Any ideas what's going on, or what I can do?  I can always kick
the box and just power cycle it, but this is not a good thing.  It's the
second time tux froze on me on this box, and I've only had it running
for a couple of days.


Ideas?  Things to look for?  Things to try?  I plan on trying it later
with different settings, but...


Thanks,
Nicholas






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []