[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

AW: TUX keeps forgetting virtual_host



Great, that works. It does not work with /etc/sysctl.conf, but if I put it in sysctl.tux, the values are shown when starting the server.

thanks a lot, quick answer !!

jhh

-----Ursprungliche Nachricht-----
Von: Alex Antropoff [mailto:alex@tirastel.md]
Gesendet: Sonntag, 16. Juni 2002 15:18
An: tux-list@redhat.com
Betreff: Re: TUX keeps forgetting virtual_host


On Sun, Jun 16, 2002 at 02:30:28PM +0200, Jan-Hendrik Heuing wrote:
> Hi !
> 
> I am using RedHat 7.3, and TUX 2.2.7.
> 
> If I use 
> echo 1 > /proc/sys/net/tux/virtual_server
> to enable virtual hosting, anything works fine. I can restart TUX and anything is just working.
> 
> The problem:
> If I restart the server, tux forgets all about what I set up. It switches virtual_server back to 0, and I have no idea why. Is it meant to do that, and I have to enable virtual hosting each time I start the server ?!? I am not quite sure, but I think it worked before in earlier experiments...
proc fs is just unified access to kernel variables,
so after restarting your server you must set up all needed variables.
Simlest way to do it is to add them to /etc/sysctl.conf
f.e. sys.net.tux.virtual_server=1 
> 
> Problem2: Looks like /etc/tux.mime.types is not used:
> TUX/redirect                    pl php
> Anyway, I might fix that somehow if the first problem is solved. One after the other... ;)
> 
> thanks,
> Jan-Hendrik

-- 
Regards, 
Alex Antropoff



_______________________________________________
tux-list mailing list
tux-list@redhat.com
https://listman.redhat.com/mailman/listinfo/tux-list





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []