[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: manual up2date?



this is what I get... 

#rpm -q --redhatprovides libcrypto.so.0
error: cannot open Packages index using db3 - No such file or directory (2)
# rpm -q --whatprovides libcrypto.so.0
no package provides libcrypto.so.0

----- Original Message ----- 
From: "Michael Schwendt" <rh0210ms arcor de>
To: <valhalla-list redhat com>
Sent: Friday, December 13, 2002 10:43 PM
Subject: Re: manual up2date?


> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> On Fri, 13 Dec 2002 07:18:08 -0500, Michael Fratoni wrote:
> 
> > > >actually I was curious how would one go about finding out in what
> > > > package the files that are needed are in.
> > > >
> > > >error: failed dependencies:
> > > >        libcrypto.so.0 is needed by python-1.5.2-27.6.x
> > > >        libssl.so.0 is needed by python-1.5.2-27.6.x
> > >
> > > use google.... query like so:
> > > rpm libcrypto.so.0
> > 
> > Or, install the rpmdb-redhat package, and just ask rpm.
> > $ rpm -q --redhatprovides libcrypto.so.0
> > openssl095a-0.9.5a-16
> 
> The -q is included within the --redhatprovides alias already.
> Saves some typing.
> 
> The second helper alias for the rpmdb-redhat package
> is --redhatrequires:
> 
> $ rpm --redhatrequires kernel-drm
> XFree86-4.2.0-8
> $ rpm --redhatrequires iptables
> iptables-ipv6-1.2.5-3.009
> $ rpm --redhatrequires /etc/redhat-release 
> autofs-3.1.7-28
> 
> - -- 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.6 (GNU/Linux)
> 
> iD8DBQE9+fIX0iMVcrivHFQRAmDhAJoC2TxWBoXf8nUd7UYHidk0+GsHPwCfTa99
> Mrdln+qGvPeJw1XhxY5iFf8=
> =foBA
> -----END PGP SIGNATURE-----
> 
> 
> 
> _______________________________________________
> Valhalla-list mailing list
> Valhalla-list redhat com
> https://listman.redhat.com/mailman/listinfo/valhalla-list
> 





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]