[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Linux Samba Client Printing



I'm using RHL 7.3, and I'm not getting any error messages at all. When I do a "print /etc/hosts" from within smbclient, I get this informational message:

putting file /etc/hosts as hosts-12657 (24.0 kb/s) (average 24.0 kb/s)

Whenever I print from an app (Mozilla, Kedit, etc.), I get no error messages either.

Did you use a utility to set up your winxp printer within RHL 8? If so, what's the name of the utility? Or did you edit printcap, smb.conf, and/or other files to manually set it up? Do you use a canon driver on your RHL 8 machine and the canon driver on the winxp machine? I read in the RHL 7.3 customization guide that if there's a printer driver on the win machine that I should set up the print driver on RHL as either raw print queue or postscript so the data doesn't get filtered more than once before going to the printer. I tried both raw print queue and bjc6000a1.upp as print drivers, but I get the same results: no error messages and no output on the printer.

Is cups supported with RHL 7.3?

I changed the driver type in printconf-gui from bjc6000a1.upp to gimp-print, and now at least I get some output on the printer. Text prints as double-width; graphics prints doubly wide as well and across pages (the RHL logo printed across 3 pages, for example). Any ideas? Here's my printcap entry when using gimp-print as the driver:

lpd:\
   :ml=0:\
   :mx=0:\
   :sd=/var/spool/lpd/lpd:\
   :af=/var/spool/lpd/lpd/lpd.acct:\
   :sh:\
   :lp=|/usr/share/printconf/util/smbprint:\
   :lpd_bounce=true:\
   :if=/usr/share/printconf/util/mf_wrapper:




Sat, 14 Dec 2002 16:04:58 "S. Cowles" <scowles earthlink net> wrote:


sc> very specifically, what are the error messages you're getting? from the
sc> linux box and from the windows box.


sc> i am successfully printing from rh8.0 to a canon bjc85 hosted on a winxp
sc> pro box with no problems. on rh8.0, there is direct support for smb
sc> protocol printing within cups. works beautifully.


===========================================
Saturday, December 14, 2002, 9:15:11 AM, philbrog ptd net wrote:

pb> I have a Canon BJC-600 printer attached to a m$ windows 98 machine.
pb> From my RHL machine I can smbclient to the m$ machine, so Samba and the
pb> network are working. I set up a printer using printconf-gui, but I
pb> can't print on the m$ printer. I ran smbclient \\\\ms\\canon -P -d10,
pb> then did a print /etc/hosts, and the debug output shows that smbclient
pb> sent the /etc/hosts file, but nothing appears on the printer. There is
pb> no password required to access the printer. A 2nd m$ machine on my
pb> network can print successfully to the Canon printer. Should I delete
pb> the entry for the Canon printer from printconf-gui and start all over
pb> again? Should I consult linuxprinting.org or samba.org? Should I start
pb> with linuxprinting.org first or samba.org first? Thanks for your time.







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]