[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: loading sound modules



> > All was in /etc/modules.conf as you said, but adding
> > /bin/aumix-minimal-f /etc/.aumixrc to the rc.local did not work, nor
> > did running aumix as a user. I did a lsmod (nosound) and a lsmod
> > after running 'sndconfig'(with sound) -- the diff between the two is
> > listed below. 
> > 
> > 
> >   [smlake walrus smlake]$ diff sound-none sound-with
> >   1a2,3
> >   > es1371                 29056   0 
> >   > soundcore               6692   4  [es1371]
> >   3d4
> >   < es1371                 29056   0  (autoclean)
> >   6d6
> >   < soundcore               6692   4  (autoclean) [es1371]
> > 
> > 
> > It's odd that I have this issue on the desktop as I have RH7.3
> > running on a laptop (thinkpad 770) where CDs will play automatically
> > -- although I needed to disable the 'quick boot' option in the bios
> > on the laptop for that to happen. According the the linux-thinkpad
> > mailing list something in the 'quick boot' pnp needs to be disabled
> > for sound on a thinkpad.
> > 
> > Thanks.
> > 
> > /SMichelle
> > 
> Strange.  Well, you can put "modprobe es1371" in rc.local, and it will
> 
> load the modules for you.  You shouldn't need to do it, but it will
> work for now.
> 
> Mikkel
> -- 


It gets stranger. I added "modprobe es1371" to rc.local ... and yet
still no sound without running 'sndconfig'. The diff between the two
lsmod's (after running sndconfig) and directly after boot with the
"modprobe es1371".

  [smlake walrus smlake]# diff sound-with sound-module
  1a2
  > sr_mod                 16920   0  (autoclean)
  4,9d4
  < ppp_deflate             4032   0  (autoclean)
  < zlib_deflate           21344   0  (autoclean) [ppp_deflate]
  < ppp_async               8256   1  (autoclean)
  < ppp_generic            24108   3  (autoclean) [ppp_deflate
ppp_async]
  < slhc                    6508   1  (autoclean) [ppp_generic]
  < sr_mod                 16920   0  (autoclean)

Any other ideas on which additional modules need to be loaded and/or
other workarounds?

Thanks.

/SMichelle





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]