[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Failed to print



Can anyone who is familiar with the printer setup
help?

I have two PCs on my private LAN. One is Win2K server,
the other is Red Hat Linux 7.3 server. I have been
trying in vain to set up both local and SMB printer on
the Linux machine to print to the Minolta QMS PagePro
4100 laser printer.

I ran the printconfi-gui to set up both the local and
the SMB printers on the Linux box. Neither printer
works. The /etc/printcap looks like this:

smb|qms:\
        :ml=0:\
        :mx=0:\
        :sd=/var/spool/lpd/smb:\
        :af=/var/spool/lpd/smb/smb.acct:\
        :sh:\
        :lp=|/usr/share/printconf/util/smbprint:

local:\
        :ml=0:\
        :mx=0:\
        :sd=/var/spool/lpd/local:\
        :af=/var/spool/lpd/local/local.acct:\
        :sh:\
        :lp=/dev/lp0:\
        :lpd_bounce=true:\
        :if=/usr/share/printconf/util/mf_wrapper:

For the local printer, I tried to print a text file
but it did not print to the printer. I even tried to
print directly to the printer by this command:

$ cat /etc/printcap > /dev/lp0

Nothing happened.

Then I tried to set up the SMB printer and made it
default printer.

On the Win2K PC, the "Location" of the printer
properties was set to "WIN2K", the host name of the
Win2K PC where the printer is connected. The "Shared
as" has value "QMS". On the Linux side, the Queue Type
tab has the following parameters:

Share: //WIN2K/QMS
Host IP: 10.0.0.10 (the local IP of the Win2K PC)
Workgroup: MYGROUP (the workgroup of the Win2K PC)
User: an account name
Password: its password
Translate \n=>\r\n checked

The driver of the printer is set to "Raw Printer
Queue" .

When I was testing the SMB printer by sending a test
page, I could see the printer status had received the
test page indicating the test page was indeed sent to
the printer. But nothing got printed on the printer. I
can print pages to the printer from the Win2K PC with
no problems.

Now I've got the RH Linux 7.3 running without a
printer facility. I have tried very hard to set the
printer many times. I cannot succeed in getting either
local or SMB printer working.

I would appreciate it very much if anyone could help!
Thanks very much.

John Chen   :-(



__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]