[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Software RAID Issues



Hi there.

 Ok.. First, I am using the stock Valhalla kernel. I have a bunch of old ide
and
scsi hard drives that I want to make into a raid-linear to combine their
capacities. Second, I want to mirror the raid-linear to a 200gb Caviar drive
that was given to me using raid-1. Problem is, it doesn't seem to work. When
I run # mkraid /dev/md0 and dev/md1, the raid arrays are successfully
created. The problem lies in the mirroring. I can mount both arrays and
access them, but when data is written to md0, no data gets mirrored to md1.
I also get lots of weird drive seek errors and other such things on boot
occasionally. I did try another way, which I will get to if asked, but this
is the way I would prefer to do it since it would be easier to retrieve data
off the mirror drive in the event of a linear drive failure. Any ideas?
Below is a paste of the raidtab file I tried. Let me know if anyone sees
something wrong with it:

 raiddev /dev/md0
     raid-level linear
     nr-raid-disks 10
     nr-spare-disks 0
     chunk-size 4
     persistent-superblock 1
     device /dev/hdb
     raid-disk 0
     device /dev/hdc
     raid-disk 1
     device /dev/hde
     raid-disk 2
     device /dev/hdf
     raid-disk 3
     device /dev/hdg
     raid-disk 4
     device /dev/hdh
     raid-disk 5
     device /dev/hdi
     raid-disk 6
     device /dev/hdj
     raid-disk 7
     device /dev/sdc
     raid-disk 8
     device /dev/sdd
     raid-disk 9

 raiddev /dev/md1
     raid-level 1
     nr-raid-disks 2
     nr-spare-disks 0
     chunk-size 4
     persistent-superblock 1
     device /dev/hdk
     raid-disk 0
     device /dev/md0
     raid-disk 1

 Thanks.. :) Any and all help is appreciated.. Gee, after I get this worked
out, perhaps I can move on to Samba. :)

Michael






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]