[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ssh hangs for a long time



I wonder if anyone has seen the following problem and knows how to fix
it.

Trying to ssh from RH7.3 to a RH7.2 machine (with all the
errata/updates) *sometimes* (not all the time) I see the connection
hang for a long time before I get a password prompt. More
specifically (trillian is a RH7.2 machine, the client is a RH7.3
machine, with a LAN, actually a crossed ethernet cable, between them),

$ ssh -v -v oleg trillian
OpenSSH_3.1p1, SSH protocols 1.5/2.0, OpenSSL 0x0090602f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: restore_uid
debug1: ssh_connect: getuid 500 geteuid 0 anon 1

   Here the connection hangs, sometimes for minutes (though not always).

debug1: Connecting to trillian [192.168.0.2] port 22.
debug1: temporarily_use_uid: 500/100 (e=0)
debug1: restore_uid
debug1: temporarily_use_uid: 500/100 (e=0)
debug1: restore_uid
debug1: Connection established.

and then everything goes as expected. The /etc/ssh/ssh_config on the
server side is the one that comes with the system, I believe. In any
case, the only uncommented stanza there is

Host *
        ForwardX11 yes

Has anyone got any ideas?

Thanks,

-- 
Oleg Goldshmidt | pub NOSPAM goldshmidt org





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]