[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Unable to access part of a 250 GB disk



Steven J. Yellin wrote:
The problem I had accessing all of a >137GB disk is fixed. On my Tyan
S2507T Dual Socket motherboard is a VIA vt82c686b IDE UDMA100 controller,
and the disk interface of the Western Digital WD2500JB is Ultra ATA/100. It was not necessary to get a special controller that supports 48 bit
addressing; the one already there can do it provided the kernel is recent
enough. Forrest (Thank you!) pointed out my blunder in an earlier note to
this list: I tried to extend the last partition without first resizing
/dev/hda4, the "Extended" system. When I later used parted to resize
/dev/hda4 and then /dev/hda9, I still ran into trouble, with parted saying
it's necessary to reinstall the boot loader. Instead I started over
without a /dev/hda9 partition, upgraded the kernel to the most recent
RedHat one, which can handle LBA48, resized /dev/hda4, rebooted, used
fdisk and mke2fs to include the rest of the disk on /dev/hda9, and
rebooted again. The full disk is now accessible:


/dev/hda9 1225 30401 234364221 83 Linux

For future reference, which kernel worked, and which one(s) did not?


Forrest
--





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]