[vfio-users] Guest does not boot OS with GPU passed through, stuck at TianoCore boot splash

Stefan Seil stefan.seil at gmx.net
Mon Apr 11 15:18:21 UTC 2016

I have assigned two CPU cores to the VM and the performance graph in 
virt-manager shows a constant 50-51% usage.
I have created two simple virtual drives (both IDE, raw), one to use as 
a hard disk and one for a CDROM drive to boot the installation image. 
This was done in the setup wizard in virt-manager, so this is more or 
less the default configuration I guess. As I said before, the VM boots 
this without problems if I remove the assigned graphics card from it.
I don't pass through anything but the two PCI devices for my graphics 
card (one for the GPU, one for the HDMI audio).

I tried converting the XML configuration to qemu arguments with 
domxml-to-native, but I get this error every time:

Error: Internal Error: invalid PCI passthrough type 'default'

I have searched for an explanation and potential solution to this error, 
but the only thing I found was about a bug in libvirt from two years 
ago, so I am not sure what this error is supposed to mean. I will have 
to further investigate this.
For reference, here is the XML configuration: http://pastebin.com/RNDhgdK1

Am 10.04.2016 um 16:46 schrieb Blank Field:
> 100% one core CPU?
> What kind of disk device you have?
> Are you passing through a physical disk?
> What you can do - convert libvirt xml into a usual qemu command line, 
> and add an ISA debug console and check OVMF debug output in it.
> On Apr 10, 2016 5:04 PM, "Stefan Seil" <Stefan.seil at gmx.net 
> <mailto:Stefan.seil at gmx.net>> wrote:
>     Hello there!
>     I am trying to set up a PCI passthrough for my graphics card. I
>     followed the instructions on vfio.blogspot.com
>     <http://vfio.blogspot.com> and used vfio-pci and OVMF, and so far
>     everything seemed to work fine. When I now try to start the VM
>     with my graphics card passed through, though, it shows the
>     TianoCore boot splash (with the successfull memory test notice on
>     the bottom) on the monitor connected to the card and stops there.
>     I tried waiting for quite a while, but it is stuck at this boot
>     splash. If I remove the PCI devices from the VM, the OS boots
>     without problems.
>     I don't see any error messages in any of the relevant logs I can
>     think of (libvirt log, dmesg, virt-manager itself). The only line
>     showing up in the libvirt log (/var/log/libvirt/qemu/...) is the
>     following:
>     2016-04-10 10:45:08.461+0000: starting up libvirt version: 1.3.2,
>     package: 0~15.10~ppa0 (Jacob Zimmermann <ppa at jzimm.net
>     <mailto:ppa at jzimm.net>> Fri, 04 Mar LC_ALL=C
>     PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin QEMU_AUDIO_DRV=spice
>     /usr/bin/kvm-spice -name xubuntu2 -S -char device redirected to
>     /dev/pts/9 (label charserial0)
>     I don't really have an idea what the problem could be, especially
>     since there are no errors showing up. I am using an Intel Core
>     i5-3470, a Sapphire HD 7850 (AMD) and Xubuntu 15.10 on the host. I
>     installed all the relevant tools from a PPA by Jacob Zimmermann in
>     order to get more recent versions of qemu, virt-manager and the likes.
>     One thing I should note is that the ROM of my graphics card does
>     not support UEFI out of the box. As it is, the passthrough did not
>     work at all; there was nothing showing up on the monitor connected
>     to the card. I found a ROM from a similar model by Gigabyte that
>     supports UEFI, though, and passed it to the VM. Now the monitor
>     shows the TianoCore boot splash, but stops there. Could this be
>     the problem? I would think that it should work this way, though,
>     as the boot splash is already passed to the card; otherwise there
>     would be nothing showing up on the monitor, right?
>     _______________________________________________
>     vfio-users mailing list
>     vfio-users at redhat.com <mailto:vfio-users at redhat.com>
>     https://www.redhat.com/mailman/listinfo/vfio-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/vfio-users/attachments/20160411/0daf1ef9/attachment.htm>

More information about the vfio-users mailing list