[vfio-users] Nvidia Code 43 on Fedora 24 host and Windows 10 guest.

Alex Williamson alex.williamson at redhat.com
Wed Oct 5 01:19:09 UTC 2016

On Tue, 4 Oct 2016 21:40:17 +0200
Dawid Osuchowski <tulphoon at openmailbox.org> wrote:

> I've rebooted the machine, the lspci output was the same without
> launching anything prior to it.
> If by OVMF boot splash screen you mean the "TianoCore" screen before the
> OS is starting, then yes i'm able to see it.
> I've put the ROM file in the /usr/share/qemu directory and run
> restorecon on it (and changed the path in virsh) as you've suggested and
> booted up the VM, still doesn't work. I've changed slot from 0x02 to
> 0x08, had to reinstall the drivers, because system just freaked out and
> it still doesn't work afterwards.
> The AUX power cord is connected to the GPU. I've been using this card
> before as a main GPU for this machine and then decided to give
> passthrough a go.
> Driver version is 372.90.

I happen to have an EVGA GTX660, so I did a clean FC24 host install,
followed my blog using your email and XML to see what paths you took,
and it all worked like it's supposed to.  But my GTX660 has UEFI
support in the onboard ROM, so I didn't need to specify a stand-alone
ROM.  Trying to align more to your configuration I dumped the ROM using
GPU-z in the guest (I wasn't able to get it from the Linux host
directly).  When I specify this ROM for the VM, the ROM dump from my
own card, I now get Code43 in the guest.  So, I don't have answers
yet, I need to see if the ROM differs from a bare metal GPU-z dump as
well as from what QEMU reads from the card.  Barring differences there,
see if I can find any differences in handling of the ROM for native vs
side-load.  Thanks,


More information about the vfio-users mailing list