[virt-tools-list] "Shared physical device" networking in virt-manager doesn't work for remote libvirtd instance

Cole Robinson crobinso at redhat.com
Mon Dec 7 17:51:52 UTC 2009

On 12/06/2009 06:08 PM, Dale Bewley wrote:
> ----- "Cole Robinson" <crobinso at redhat.com> wrote:
>> On 12/05/2009 11:47 PM, elias wrote:
>>> Hi,
>>> I'm running libvirt-0.7.4 on a remote Gentoo server.
>>> I'm connecting to it using virt-manager-0.8.1 on Gentoo.
>>> When trying to create a new VM (KVM) using the 'New VM' wizard, I'm
>> not able 
>>> to select an existing bridge device as "Shared physical device" -
>> the 
>>> 'Advanced options' section does only show the default virtual
>> network.
>>> When taking a look at ~/.virt-manager/virt-manager.log, there are 2
>>> interesting lines:
>>> [Sun, 06 Dec 2009 05:40:17 virt-manager 31743] DEBUG
>> (connection:1100) 
>>> Connection doesn't seem to support interface APIs. Skipping all
>> interface 
>>> polling.
>>> [Sun, 06 Dec 2009 05:40:19 virt-manager 31743] DEBUG
>> (connection:202) Libvirt 
>>> version does not support physical interface listing
>>> So I tried to understand the code of virt-manager and it seems to
>> me, that 
>>> setting up a shared physical device for networking isn't possible
>> for remote 
>>> hosts - is this true?
>> Like the log output says, virt-manager doesn't think your libvirt
>> instance supports remote bridge listing. You can test this by trying
>> the virsh iface-list command on the remote host: if it fails,
>> virt-manager was correct.
> I see the same problem, however I do have netcf-libs.
> [dlbewley at seitan .virt-manager]$ virsh -c qemu+ssh://root@sammy/system iface-list
> Name                 State      MAC Address
> --------------------------------------------
> br200                active     00:15:60:04:45:ad
> eth0                 active     00:26:18:3a:2c:27
> lo                   active     00:00:00:00:00:00
> The br200 interface is grayed out in the new VM wizard running locally against libvirtd on remote host sammy. It is only possible to select the 'default' network. 
> If I run virt-manager on the remote server it does allow for selection of br200.
> Both local and remote versions are:
> libvirt-0.7.1-15.fc12.x86_64
> virt-manager-0.8.1-1.fc12.noarch
> netcf-libs-0.1.5-1.fc12.x86_64
> python-virtinst-0.500.1-1.fc12.noarch
> Also, in virt-manager.log I see the following repeating over and over. I have a 1M log after about 3 minutes. This is the case for virt-manager running on both local and remote hosts:
> [Sun, 06 Dec 2009 14:45:57 virt-manager 17064] ERROR (connection:1114) Unable to list inactive interfaces
> Traceback (most recent call last):
>   File "/usr/share/virt-manager/virtManager/connection.py", line 1112, in _update_interfaces
>     newInactiveNames = self.vmm.listDefinedInterfaces()
> TypeError: listDefinedInterfaces() takes exactly 3 arguments (1 given)
> [Sun, 06 Dec 2009 14:45:57 virt-manager 17064] ERROR (connection:1110) Unable to list active interfaces
> Traceback (most recent call last):
>   File "/usr/share/virt-manager/virtManager/connection.py", line 1108, in _update_interfaces
>     newActiveNames = self.vmm.listInterfaces()
> TypeError: listInterfaces() takes exactly 3 arguments (1 given)
> The remote system (sammy) has no other connections in virt-manager beyond its self. It has this same error filling the log.

Ah okay, thanks for the report. This is because until recently the
python bindings for the libvirt interface APIs were busted (and are
busted in your libvirt version). We try to detect this in
virt-manager/virtinst, but the detection didn't account for the above error.

I'll fix this upstream and make sure the virtinst fix is pulled in for
F12. Probably also a good idea to backport the python interface API
fixes for F12 libvirt.

- Cole

More information about the virt-tools-list mailing list