[virt-tools-list] problems with domain installation

Cole Robinson crobinso at redhat.com
Mon Dec 14 14:14:44 UTC 2009

On 12/14/2009 02:26 AM, Tomas Macek wrote:
> On Fri, 11 Dec 2009, Cole Robinson wrote:
>> Hmm, I just tried this and reproduced your failure. However, changing
>> the extra args from '-x console=/dev/ttyS0' to just '-x console=ttyS0'
>> fixed it for me. Sorry I mentioned the incorrect args on IRC yesterday,
>> hopefully the above fix helps you out.
> Thank you very much! This made the job! The "-x console=ttyS0" is the
> proper variant for this option :)
> I tried this with Debian Etch and Fedora 12. The Fedora 12's Anaconda
> failed with traceback, Debian finished the installation well, but I've
> forget to redirect the output from the system and now it's unreachable :))
> But the things are now OK - I'm able to install in text console and
> that's great. Maybe this example could be a part of manual page...
> I've also tried to pass the "-x console=ttyS0" when installing from ISO
> image from the disk. This does not work - I know it should not work,
> because of the manual "Additional kernel command line arguments to pass
> to the installer when performing a guest install from "--location".
> I'm I somehow able to pass the kernel commands and so redirect the
> output to ttyS0 when installing from ISO image from the disk?

The only way to do it is to manually edit files in the iso to add kernel
command line arguments. It's a pain.

- Cole

More information about the virt-tools-list mailing list