[virt-tools-list] RE: [et-mgmt-tools] virt-p2v problems

Ribeiro Emerson Gomes Emerson.Ribeiro at scania.com
Fri Jul 17 12:27:56 UTC 2009


I have edited /etc/xen files to use bond-bridge network script instead
of bridge net script. That's because we bond two NICS together
(BONDING_OPTS="mode=active-backup miimon=80"). Not sure if that is
related to the problem in any way.

Yes, "virsh list" throws the same error:

[root at blpc6]# virsh list --all
libvir: error : configuration file syntax error: expecting a name
 Id Name                 State
  0 Domain-0             running
  - emerson3_br_scania_com shut off

I have never noticed it because we manage guests through Conga.

/etc/libvirt/qemu/networks/default.xml is the only conf file I have for
libvirt and it looks like this:

  <bridge name="virbr0" />
  <ip address="" netmask="">
      <range start="" end="" />

I'm not really sure whether it has been edited or not because we install
it from a global Satellite server and someone overseas might have edited

The one million question: where is libvirt expecting for a name?


-----Original Message-----
From: Cole Robinson [mailto:crobinso at redhat.com] 
Sent: Thursday, July 16, 2009 6:00 PM
Cc: Richard W.M. Jones; Ribeiro Emerson Gomes; Fedora/Linux Management
Subject: Re: [et-mgmt-tools] virt-p2v problems

Ribeiro Emerson Gomes wrote:
> Hey,
> I narrowed the config file down to:
> 	<domain type="xen">
> 	  <name>emerson3</name>
> 	  <uuid>3ffcff461be5cef1ff45ffe1bb71b17a</uuid>
> 	  <memory>2095104</memory>
> 	</domain>
> and I still get the very same error. 
> Maybe a missing tag??
> Emerson

(Let's move to virt-tools-list)

That 'expecting a name' error shouldn't have to do with the XML file:
did you manually any of the libvirt .conf files, or do you have hand
editted files in /etc/xen? Do other virsh commands (list --all) throw

- Cole

More information about the virt-tools-list mailing list