[virt-tools-list] virt-install 0.400-3: cannot install

Gerry Reno greno at verizon.net
Sun Nov 22 18:20:31 UTC 2009

Cole Robinson wrote:
> On 11/22/2009 01:12 AM, Gerry Reno wrote:
>> I'm trying to do a text-based install using virt-install 0.400-3 on a
>> ubuntu server 9.10 but it is refusing to install.  Here is the form of
>> the command I'm using:
>> $ sudo -s
>> # virt-install -n "DOMAIN-1" --vcpus=4 --ram=2048 --disk
>> path=/var/lib/libvirt/images/DOMAIN-1.img
>> --location=http://mirrors.us.kernel.org/ubuntu-releases/karmic/ubuntu-9.10-server-amd64.iso
>> --accelerate --network=bridge:br0 --nographics
>> --extra-args="console=tty0 console=ttyS0,115200"
>> I've tried local, nfs, http for locations and it either says its not an
>> installable distribution or I get a ValueError: Invalid install
>> location.  But I can wget the iso with no problem using the same url.
>> Can anyone point me to what is wrong with my command line?
> --location needs to point to an install tree, not an iso. You should be able
> to replace --location with --cdrom to make things work. This is described in
> the virt-install man page.
> HTH,
> Cole
Ok, I just tried it replacing --location with --cdrom and it gives me 
the exact same ValueError: Invalid install location Opening URL http://....

So I nfs mounted the iso across the network and then passed the 
mountpoint to --cdrom and this at least creates the domain but then it 
just sits there at "Escape is ^]" and does not do anything else.

Is there something wrong with my console args?


More information about the virt-tools-list mailing list