[virt-tools-list] virt-install 0.400-3: cannot install

Gerry Reno greno at verizon.net
Sun Nov 22 19:04:44 UTC 2009

Gerry Reno wrote:
> Cole Robinson wrote:
>> On 11/22/2009 01:20 PM, Gerry Reno wrote:
>>> Cole Robinson wrote:
>>>> On 11/22/2009 01:12 AM, Gerry Reno wrote:
>>>>> I'm trying to do a text-based install using virt-install 0.400-3 on a
>>>>> ubuntu server 9.10 but it is refusing to install. Here is the form of
>>>>> the command I'm using:
>>>>> $ sudo -s
>>>>> # virt-install -n "DOMAIN-1" --vcpus=4 --ram=2048 --disk
>>>>> path=/var/lib/libvirt/images/DOMAIN-1.img
>>>>> --location=http://mirrors.us.kernel.org/ubuntu-releases/karmic/ubuntu-9.10-server-amd64.iso 
>>>>> --accelerate --network=bridge:br0 --nographics
>>>>> --extra-args="console=tty0 console=ttyS0,115200"
>>>>> I've tried local, nfs, http for locations and it either says its 
>>>>> not an
>>>>> installable distribution or I get a ValueError: Invalid install
>>>>> location. But I can wget the iso with no problem using the same url.
>>>>> Can anyone point me to what is wrong with my command line?
>>>> --location needs to point to an install tree, not an iso. You should
>>>> be able
>>>> to replace --location with --cdrom to make things work. This is
>>>> described in
>>>> the virt-install man page.
>>>> HTH,
>>>> Cole
>>> Ok, I just tried it replacing --location with --cdrom and it gives me
>>> the exact same ValueError: Invalid install location Opening URL 
>>> http://....
>> Argh, yes. I was wrong about that, --cdrom also expects a top level 
>> distro
>> path. That should be fixed though, to just allow pointing to a cdrom 
>> like you did.
>>> So I nfs mounted the iso across the network and then passed the
>>> mountpoint to --cdrom and this at least creates the domain but then it
>>> just sits there at "Escape is ^]" and does not do anything else.
>>> Is there something wrong with my console args?
>> If you boot off a cdrom, kernel args have no effect, since we have no 
>> way to
>> pass them in to the cd. Extra args only work if you directly boot a 
>> kernel.
>> You should be able to try using
>> --location 
>> http://mirrors.us.kernel.org/ubuntu/dists/karmic/main/installer-amd64/
>> which will do a direct kernel boot, allowing extra args.
>> - Cole
> I think our posts just crossed. I try this and get back...
> -Gerry
Ok, that location is working but the guest network is behaving painfully 
slow. I have a 20Mbps service but the install file retrieval is going 
like 56kbps. Ugh...


More information about the virt-tools-list mailing list