[virt-tools-list] Clone on started pool fails

Frédéric Grelot fredericg_99 at yahoo.fr
Tue Nov 24 13:37:52 UTC 2009


I just experienced an error while trying to clone a vm whose disk is on a pool (other than /var/lib...).
The error is triggered by VirtualDisk.py:731 and says :
ERROR    Could not determine original disk information: Size must be specified for non existent volume path '/raid5/vms/disk.qcow2'

where disk is the source vm disk, and of course exists... /raid5 is an lvm mount, on top of a raid5 disk array.
After reading the code in VirtualDisk.py, i suspected a problem with the pool, and by "stopping" it (in virt-manager/storage manager), cloning suddently works without problem!
I tried with the cli (virt-clone --prompt) version, as of the gui (virt-manager/clone), and get the exact same error...
When I first tried, the disk was a plain 18Gb ".img" file, when I realized that, i converted it to a qcow2 one (7gb).

By the way, I just realized that it may be linked to another problem (... 2s later : confirmed) : whenever I try to add a disk to a new vm, or when I want to create a vm, I always get an error : "Name 'any_disk.ext' already in use by another volume.", where any_disk.ext can be a .img raw disk, qcow2, etc...  ...and of course is not an already used disk! I just tested by "stopping" the pool (and the "browse local" option of virt-manager), and adding a disk works! (At last, I don't need to add disks by hand in /etc/libvirt/qemu/*.xml anymore...)

I'm not sure whether it is a bug or a mis-configuration, I already heard that I should better use only the /var/lib/...image/ directory as a pool, but using my /raid5 volume gives me more flexibility and visibility, so I'd prefer keep using it...

So I'll take any help to solve this, and, if you need more information, I'll give them to you with pleasure!


Pool definition :
<pool type='dir'>

Versions :
# rpm -qa | grep virt

More information about the virt-tools-list mailing list