[virt-tools-list] setting memory at runtime fails?

Thomas Fjellstrom tfjellstrom at shaw.ca
Sun Aug 8 06:57:43 UTC 2010


I've tried on several occasions to use the virt-manager to set memory in a 
guest at run time, but all it seems to do is set memory in the guest to a 
very small amount regardless of what number I actually chose (trying to use 
a number in KB doesn't work, the gui seems to have issues with it. it'll set 
the max mem, but trying to set mem to anything that large will just make it 
go back to the previous allocation).

I just tried it again with virt-manager, memory was set to 256M, I told it 
to increase to 512MB, and it instantly dropped to 70MB and the guest 
OOMKilled every process. Then I forced the guest off, then tried to restart 
it and virt-manager decided to say it was going to set the memory to 1024MB, 
then crash. Though it did start the guest, but only with the 512MB I 
increased it to in the last step.

virsh seems to work fine to reduce the memory in a vm. I did notice that 
virsh takes KB and virt-manager takes MB. Is it possible that virt-manager 
isn't doing the necessary conversion to KB when calling into libvirt?


Thomas Fjellstrom
tfjellstrom at shaw.ca

More information about the virt-tools-list mailing list