[virt-tools-list] setting memory at runtime fails?

Thomas Fjellstrom tfjellstrom at shaw.ca
Tue Aug 10 05:06:37 UTC 2010

On August 9, 2010, Cole Robinson wrote:
> On 08/08/2010 02:57 AM, Thomas Fjellstrom wrote:
> > Hi,
> > 
> > I've tried on several occasions to use the virt-manager to set memory
> > in a guest at run time, but all it seems to do is set memory in the
> > guest to a very small amount regardless of what number I actually
> > chose (trying to use a number in KB doesn't work, the gui seems to
> > have issues with it. it'll set the max mem, but trying to set mem to
> > anything that large will just make it go back to the previous
> > allocation).
> > 
> > I just tried it again with virt-manager, memory was set to 256M, I told
> > it to increase to 512MB, and it instantly dropped to 70MB and the
> > guest OOMKilled every process. Then I forced the guest off, then tried
> > to restart it and virt-manager decided to say it was going to set the
> > memory to 1024MB, then crash. Though it did start the guest, but only
> > with the 512MB I increased it to in the last step.
> > 
> > virsh seems to work fine to reduce the memory in a vm. I did notice
> > that virsh takes KB and virt-manager takes MB. Is it possible that
> > virt-manager isn't doing the necessary conversion to KB when calling
> > into libvirt?
> More info is really required here: versions for virt-manager, virtinst,
> libvirt, and qemu or xen depending on what you are using. If you can
> provide the output of virt-manager --debug when reproducing this series
> of events it would help track down the issue.

libvirt-bin 0.8.2-1 
virt-manager 0.8.4-7
virtinst 0.500.3-2

qemu 0.12.5
qemu-kvm 0.12.4+

I've attached a log of the --debug output of virt-manager for a session 
where I start it up, it connects to two of my servers (boris, kvm based, the 
one that likes to not set memory properly, and snidely xen based that we'll 
ignore for now)

After I kill the vm in that log you'll see I try to set the memory again, 
and restart the vm, but this time it just didn't start. it said it was 
running, but virt-manager didn't want to connect to the console and the 
stats for it were stuck, all I could do was "force off" again.

Actually I'm confused as to why the xen one isn't reading disk usage 
properly. Maybe it doesn't like that the xen setup is LVM backed rather than 
file backed? But then the kvm instance is lvm backed too and that works fine.

> Thanks,
> Cole


Thomas Fjellstrom
tfjellstrom at shaw.ca
-------------- next part --------------
A non-text attachment was scrubbed...
Name: virt-manager.log
Type: text/x-log
Size: 16858 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/virt-tools-list/attachments/20100809/63c8a42a/attachment.bin>

More information about the virt-tools-list mailing list