[virt-tools-list] trying virt-Manager 0.8.2 but getting error messgaes

Sharadha Prabhakar (3P) sharadha.prabhakar at citrix.com
Thu Jan 14 13:41:27 UTC 2010

I'm runnning virt-Manager 0.5.4 on debian 4.1.1-21 
Libvirt version 0.7.4, python 2.4
I'm writing a XenAPI driver for libvirt to support
XenServer. Right now, every virtManager call goes to
Libvirt and reaches my API.
The virtManager runs properly without --show-domain-creator.
But I'd like to create guest VMs using virt Manager.

-----Original Message-----
From: Cole Robinson [mailto:crobinso at redhat.com] 
Sent: 14 January 2010 13:30
To: Sharadha Prabhakar (3P)
Cc: 'virt-tools-list at redhat.com'
Subject: Re: [virt-tools-list] trying virt-Manager 0.8.2 but getting error messgaes

On 01/14/2010 08:13 AM, Sharadha Prabhakar (3P) wrote:
> I installed virtInst 0.500.1 but the errors remain.
> I'm actually trying to create new VM through virt-Manager.
> Can I do that with version 0.5.4 itself? Because with 0.5.4
> If I click the new button it say's 'Creating new guest VMs not
> yet support'. 
> Then I tried running from the command line the following
>>> LIBVIRT_DEBUG=1 virt-manager --connect="XenAPI://..." --show-domain-creator --no-fork
> I thought --show-domain-creator would enable the graphical console for
> Domain creation. Hope I'm right about it.
> Now I get the following error

Proper syntax would be virt-manager --connect="xen:/// ..."

> Traceback (most recent call last):
>   File "/usr/share/virt-manager/virt-manager.py", line 310, in ?
>     main()
>   File "/usr/share/virt-manager/virt-manager.py", line 297, in main
>     show_engine(engine, options.show, options.uri, options.uuid)
>   File "/usr/share/virt-manager/virt-manager.py", line 171, in show_engine
>     engine.show_create(uri)
>   File "/usr/share/virt-manager/virtManager/engine.py", line 314, in show_create
>     create = vmmCreate(self.get_config(), con)
>   File "/usr/share/virt-manager/virtManager/create.py", line 111, in __init__
>     self.caps = self.connection.get_capabilities()
>   File "/usr/share/virt-manager/virtManager/connection.py", line 303, in get_capabilities
>     return virtinst.CapabilitiesParser.parse(self.vmm.getCapabilities())
> AttributeError: 'NoneType' object has no attribute 'getCapabilities'
> Right now my libvirt call to getCapabilities just returns NULL. Could that be the problem?
> Is virt Manager expecting libvirt to return a meaningful XML string?
> -SP

What distro are you on? If you tried virt-manager 0.5.1, I'm guessing its
pretty old, so there could be some incompatabilities. What libvirt version are
you running?

- Cole

More information about the virt-tools-list mailing list