[virt-tools-list] Virt-install errors; cannot install guests.

Ed Hargin ed at hargin.co.uk
Thu Jan 21 15:02:42 UTC 2010

 + Running KVM-88, with a range of libvirt tools: libvirt-0.7.2,
   virtinst-0.500.0, virt-viewer-0.0.3, virt-manager-0.7.0 on Centos-5.4.
 + On boxes that previously had older versions of software (KVM-84,
   libvirt-0.6.2, virtinst-0.400.3, Centos-5.2) VMs were able to be 
installed and run
   correctly.  Previously installed VMs continue to work with the new 
 + When trying to run virt-install in the new environment, we recieve the
   following error message after virt-install has downloaded the vmlinuz 
   from the remote URL:
       ERROR    coercing to Unicode: need string or buffer, NoneType found
   This happens both when using --prompt and providing full arguments on 
   command line.  A more detailed trace can be found at the end of the 
   The same error occurs when trying use a local .iso image, and other 
 + I am perfectly happy to provide more details, particularly details of 
   exact compile/configure options used to install all components of the
   environment, just ask.  I tried to focus in on where the problem was and
   didn't want to provide too much uneccessary information and make this 
hard to
 + I believe it may (or may not) be significant that I had to hand-edit the
   hard-coded values for virt-viewer and virsh, both of which are statically
   referred to in /usr/bin within virt-install (within the vnc_console and
   txt_console functions).
Any suggestions/advice/help would be much appreciated!

Starting install...
Retrieving file vmlinuz...                               |    0 B     
ERROR    coercing to Unicode: need string or buffer, NoneType found
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start test1'; otherwise, please
 restart your installation.
ERROR    coercing to Unicode: need string or buffer, NoneType found
Traceback (most recent call last):
  File "/usr/local/libvirt/bin/virt-install", line 929, in ?
  File "/usr/local/libvirt/bin/virt-install", line 825, in main
    start_time, guest.start_install)
  File "/usr/local/libvirt/bin/virt-install", line 880, in do_install
    dom = install_func(conscb, progresscb, wait=(not wait))
  File "/usr/local/libvirt//lib/python/virtinst/Guest.py", line 626, in 
  File "/usr/local/libvirt//lib/python/virtinst/Guest.py", line 679, in 
    meter = meter)
  File "/usr/local/libvirt//lib/python/virtinst/DistroInstaller.py", 
line 246, in prepare
    self._prepare_kernel_and_initrd(guest, distro, meter)
  File "/usr/local/libvirt//lib/python/virtinst/DistroInstaller.py", 
line 194, in _prepare_kernel_and_initrd
    type=self.os_type, distro=distro)
  File "/usr/local/libvirt//lib/python/virtinst/OSDistro.py", line 137, 
in acquireKernel
    scratchdir, type, distro)
  File "/usr/local/libvirt//lib/python/virtinst/OSDistro.py", line 123, 
in _acquireMedia
    return (store.acquireKernel(guest, fetcher, progresscb),
  File "/usr/local/libvirt//lib/python/virtinst/OSDistro.py", line 242, 
in acquireKernel
  File "/usr/local/libvirt//lib/python/virtinst/OSDistro.py", line 333, 
in _kernelFetchHelper
    kernel = fetcher.acquireFile(kernelpath, progresscb)
  File "/usr/local/libvirt//lib/python/virtinst/ImageFetcher.py", line 
91, in acquireFile
    tmpname = self.saveTemp(f, prefix=base + ".")
  File "/usr/local/libvirt//lib/python/virtinst/ImageFetcher.py", line 
53, in saveTemp
    if not os.path.exists(self.scratchdir):
  File "/usr/lib64/python2.4/posixpath.py", line 171, in exists
    st = os.stat(path)
TypeError: coercing to Unicode: need string or buffer, NoneType found
==========END OF TRACE============

More information about the virt-tools-list mailing list