[virt-tools-list] Virt-install errors; cannot install guests.

Cole Robinson crobinso at redhat.com
Thu Jan 21 21:08:10 UTC 2010

On 01/21/2010 03:58 PM, Ed Hargin wrote:
> Cole Robinson wrote:
>> On 01/21/2010 10:02 AM, Ed Hargin wrote:
>>> __Overview__
>>> + Running KVM-88, with a range of libvirt tools: libvirt-0.7.2,
>>>   virtinst-0.500.0, virt-viewer-0.0.3, virt-manager-0.7.0 on Centos-5.4.
>>> + On boxes that previously had older versions of software (KVM-84,
>>>   libvirt-0.6.2, virtinst-0.400.3, Centos-5.2) VMs were able to be
>>> installed and run
>>>   correctly.  Previously installed VMs continue to work with the new
>>> upgraded
>>>   install.
>>> + When trying to run virt-install in the new environment, we recieve the
>>>   following error message after virt-install has downloaded the vmlinuz
>>> file
>>>   from the remote URL:
>>>       ERROR    coercing to Unicode: need string or buffer, NoneType
>>> found
>>>   This happens both when using --prompt and providing full arguments
>>> on the
>>>   command line.  A more detailed trace can be found at the end of the
>>> email.
>>>   The same error occurs when trying use a local .iso image, and other
>>> mirrors.
>>> + I am perfectly happy to provide more details, particularly details
>>> of the
>>>   exact compile/configure options used to install all components of the
>>>   environment, just ask.  I tried to focus in on where the problem
>>> was and
>>>   didn't want to provide too much uneccessary information and make this
>>> hard to
>>>   read.
>>> + I believe it may (or may not) be significant that I had to
>>> hand-edit the
>>>   hard-coded values for virt-viewer and virsh, both of which are
>>> statically
>>>   referred to in /usr/bin within virt-install (within the vnc_console
>>> and
>>>   txt_console functions).
>>>   Any suggestions/advice/help would be much appreciated!
>> There were a few bugs using the --prompt option in virtinst 0.500.0. I'd
>> recommend either skipping --prompt or updating to virtinst 0.500.1.
>> All prompt
>> asks you for is really
>> --name <vmname>
>> --hvm or --paravirt (for xen only)
>> --accelerate or not (for kvm only)
>> --file /path/to/an/image
>> --file-size #Gb (if the file path doesn't exist)
>> do you want a url (--location) or cdrom (--cdrom) install ?
>> install media path
>> So just fill in the above options and you should be good to go.
>> - Cole
> I upgraded to virt-install 0.500.1.  It's as if somehow there are values
> that the script is expecting that are not being passed into it.  Might
> this be because I am missing a python dependency, or the python
> environment is somehow incorrectly configured for virt-install to function?
> # virt-install --name test1 --accelerate --file /tmp/test1 --file-size
> 10 --location http://vault.centos.org/5.2/os/x86_64/ --ram 1024
> --network bridge:br0
> ERROR    need more than 1 value to unpack
> Traceback (most recent call last):
>  File "/usr/local/libvirt/bin/virt-install", line 780, in ?
>    main()
>  File "/usr/local/libvirt/bin/virt-install", line 605, in main
>    options.nonetworks, guest)
>  File "/usr/local/libvirt/bin/virt-install", line 258, in get_networks
>    networks, nics=1)
> ValueError: need more than 1 value to unpack

These line numbers don't match up with virtinst 0.500.1 code: something must
be wrong with your install and you are using an old version.

- Cole

More information about the virt-tools-list mailing list