[virt-tools-list] Connect virt-viewer to VM on remote host?

Jonathan E. Brickman jeb at ponderworthy.com
Fri May 4 12:34:01 UTC 2012

> If that really is the URL you used, then you're missing the '/system'
> part of the end ie you need
>     qemu://hostname/system
> NB, this is assuming you've configured TLS&  
What is "TLS &" ?  I tried this:

virt-viewer --connect qemu://hostname/system virtname

which gave me a popup saying "Unable to connect Unable to connect to 
libvirt with URI qemu://..."

>> Already verified that firewall is off on the host (it's Arch Linux).
>> Is there something else to do to permit connection like this?  I've
>> also tried by VM number (there's only 1 right now) and UUID, same
>> results.  I can reach the host by GUI through virt-manager very
>> well, working very nicely with sound and everything.
> If you look at the connection details in virt-manager, it should tell
> you the full URI it used - use exactly the same URI with virt-viewer.
I tried to find connection details in virt-manager, could not.  Where is 
this to be found?

Jonathan E. Brickman
/Ponderworthy Music/ <http://ponderworthy.com>
805 SW Jewell Ave
Topeka KS 66606-1610
jeb at ponderworthy.com <mailto:jeb at ponderworthy.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/virt-tools-list/attachments/20120504/08ff0ce9/attachment.htm>

More information about the virt-tools-list mailing list