[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] [PATCH] Fix default_uri xen check



The xend toolstack is deprecated upstream.  While support needs continue
for this legacy toolstack, the newer libxl toolstack does not need xend
to work.  Additionally, libvirt now has drivers for supporting the libxl
toolstack.

This patch changes the check from /var/lib/xend to /var/lib/xen
which is a common path in both toolstacks.  Neither the old path nor the
new one actually proves that xend is currently running.  It just validates
that xen has been installed on the machine.

Signed-off-by: Charles Arnold <carnold suse com>

diff --git a/virtManager/uihelpers.py b/virtManager/uihelpers.py
index a50747d..b98663b 100644
--- a/virtManager/uihelpers.py
+++ b/virtManager/uihelpers.py
@@ -1411,7 +1411,7 @@ def set_grid_row_visible(child, visible):
 
 
 def default_uri(always_system=False):
-    if os.path.exists('/var/lib/xend'):
+    if os.path.exists('/var/lib/xen'):
         if (os.path.exists('/dev/xen/evtchn') or
             os.path.exists("/proc/xen")):
             return 'xen:///'




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]