[virt-tools-list] Virtual network issue

Cole Robinson crobinso at redhat.com
Sun Nov 30 21:59:28 UTC 2014

On 11/27/2014 04:50 AM, Ondrej Holy wrote:
> Hey all,
> I tried gnome-boxes on almost fresh installation of Fedora 21. I was able to ping from guest (in my case Fedora 21 if applicable) to host, guest to internet, however host to guest communication (e.g. ssh, not only ping) didn't work (only ping to virbr0 worked). I found in "Connection details" in virt-manager that "default" network configuration with virbr0 was set "Forwarding: NAT". So I simply deleted this network configuration and created new one with "Forwarding: routed". I can ping from host to guest now, but I can't access internet.
> What am I doing wrong? I need access from host to guest and also from guest to internet (I'm connected using wifi if applicable). It should work out of box (according Christopher and it seems to be working for him on F21).

I don't know why the host and guest can't communicate... the default NAT 
network should allow, and it works fine for me here via virt-manager created 
VMs at least. Verify that the guest is getting a 192.168.* IP address, and 
isn't inadvertently using usermode networking.

mode=routed networking does not 'just work' and requires some external network 
configuration, which is why it's not doing what you expect:


- Cole

More information about the virt-tools-list mailing list