[virt-tools-list] No module named repository

Mani Devarajan manidevarajan at gmail.com
Mon Apr 20 18:43:16 UTC 2015

Hello all,
 I am trying to use virt-manager 1.1.0 with ubuntu 14.04. The apt-repo
based virt-manager doesnt support port-group. So i need to use virt-manager
1.1.0. After install i am hitting the following error.
I tried almost all the packages recommended for this problem, but still no
luck. Any suggestions on this issue would be of great help.


Traceback (most recent call last):

  File "/usr/local/share/virt-manager/virt-install", line 29, in <module>

    import virtinst

  File "/usr/local/share/virt-manager/virtinst/__init__.py", line 70, in

    from virtinst.distroinstaller import DistroInstaller

  File "/usr/local/share/virt-manager/virtinst/distroinstaller.py", line
32, in <module>

    from virtinst import urlfetcher

  File "/usr/local/share/virt-manager/virtinst/urlfetcher.py", line 35, in

    from virtinst import osdict

  File "/usr/local/share/virt-manager/virtinst/osdict.py", line 25, in

    from gi.repository import Libosinfo as libosinfo

ImportError: No module named repository

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/virt-tools-list/attachments/20150420/815b16f2/attachment.htm>

More information about the virt-tools-list mailing list