[virt-tools-list] Fwd: Remote VM no display

Ross Decker rossjdecker at gmail.com
Sat Jun 2 14:10:23 UTC 2018

I recently changed my desktop from Centos Server (GUI) to RHEL WS 7.5
(required by employer). With my Centos server as a desktop all worked

Desktop = rhel WS 7.5
Remote server = Centos 7 Server (CLI)

I launch virt-manager on my rhel desktop and all VM's work great. I
connect to my remote server and I'm asked by ksshaskpass for the root
password and connection is made with remote vm's displayed in

I launch a remote vm, and I'm asked again by ksshaskpass for the root
password = no good, it just keeps asking. The VM launches (remote
server verifies that with virt-top) but I don't get any display.

This worked perfectly with my Centos Server as a desktop.  I have X
forward in ssh, I'm using spice, I have disabled kde wallet and
ksshaskpass, but it still pop's up requesting a password, which I know
is right since it populated virt-manager with all my remote vms. I
tried the Remote server root PW and even the root PW of the VM=no joy.
When I log into the remote server I see ssh:notty errors.

I do believe it is the password request when opening a VM that is
stopping the display from showing up and nothing else..maybe...:(

Sorta lost... any ideas other than reinstalling Centos Server as my desktop?

When the power of love overcomes the love of power, the world will
know peace. --- J. Hendrix

More information about the virt-tools-list mailing list