[virt-tools-list] Docs on getting VirGL working with virt-manager?

Daniel Kasak d.j.kasak.dk at gmail.com
Sat Feb 9 00:49:32 UTC 2019

Is this even supported yet? I'm running virt-manager-2.0.0 and have tried
to launch a VM with VirGL support, but I get:

spice gl support is local-only for now and incompatible with -spice

So I tried adding a new connection in virt-manager - a QEMU/KVM user
session, and then creating the VM against that connection.

I've changed the following from the default:

Display Spice:
 - Listen type
    - Default ( Address ) - no matter what other options I choose with
this, I get "SPICE GL support is local-only ..."
    - None - I get "Error starting domain: internal error: qemu
unexpectedly closed the monitor"

Other instructions I've found around the place ( eg
https://blog.wikichoon.com/2016/05/spice-openglvirgl-acceleration-on.html )
leave my virt-manager config for the VM in an invalid state ( I get the
above error, as if I'd chosen Listen type: None )

I've found that if I install a VM ( Anroid-x86 in my case, and I believe
the current release has 'improved' support for using VirGL ) using
virt-manager, and then manually run it:

qemu-system-x86_64 -show-cursor -enable-kvm -M q35 -smp 4 -m 8G -drive
file=/var/lib/libvirt/images/Android.qcow2,if=virtio -net nic,model=virtio
-net user,hostfwd=tcp::2222-:22 -vga virtio -display sdl,gl=on

 ... it at least boots, but I get font corruption inside the VM, to the
point where I can't really use it. It's not clear whether I've got VirGL
working in this case because of the font thing. I can open a terminal and
type "dmesg | less" ... but instead of text I see an empty box symbol per
line of output. I release this particular issue has nothing to do with

So ... any ideas?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/virt-tools-list/attachments/20190209/267af2db/attachment.htm>

More information about the virt-tools-list mailing list