[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: up2date (yet again)

On Mon, Apr 02, 2001 at 11:55:33PM +0200, Andreas Thienemann wrote:
> Hmm, I stand corrected.
> The broken response from the server seemed to be only temporary.
> Now I still have the same problem as before:
> ERROR: Architecture and OS version combination is not supportet
> Any ideas?

These errors can be broken down into a couple of causes

1. Your /etc/sysconfig/rhn/systemid is claiming your running
 a release ("OS version") that isnt current available on
 the server. Verify that the value of os_release in
 the systemid file is sane.

     This is typically caused
 by the machine having a "redhat-release" package that
 isnt supposed to be there. When up2date starts up, it
 checks to see if this has changed, and if it has, it
 updates the system id to reflect the new release. 

     If you then turn around and try to talk to the
 up2date server that doesnt know about that release, it
 will give you that error message.

  If this is sane, and the server still gives this
  response, please file a bugzilla entry and attach
  (/etc/sysconfig/rhn/up2date and /etc/sysconfig/rhn/systemid)

2. Your pointing at the wrong server.

	Make sure you are pointing at beta.rhns.redhat.com/XMLRPC
   for the "serverURL" value in /etc/sysconfig/rhn/up2date

   Depending on the version of up2date, this may default to other

   The "www.rhns.redhat.com" servers _do_not_ offer packages for
   any of the beta or rawhide releases. On the same note, beta.rhns.redhat.com
   does not offer packages for any of the standard releases. 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]