[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: p2date



On Fri, Apr 06, 2001 at 01:39:29PM -0700, Philip Senechal wrote:
> I'm getting the following after running up2date
> 
> Retrieving list of all available packages...
> Traceback (innermost last):
>   File "/usr/sbin/up2date", line 821, in ?
>     main()
>   File "/usr/sbin/up2date", line 796, in main
>     sys.exit(batchRun(onlyList, pkgNames, fullUpdate))
>   File "/usr/sbin/up2date", line 426, in batchRun
>     availUpdates, skippedUpdates = up2date.getUpdatedPackageList(pkgNames,
> printit, percent)
>   File "/usr/share/rhn/up2date/up2date.py", line 1690, in
> getUpdatedPackageList
>     pkgList = getAvailablePackageList()
>   File "/usr/share/rhn/up2date/up2date.py", line 568, in
> getAvailablePackageList
>     s = getServer()
>   File "/usr/share/rhn/up2date/up2date.py", line 330, in getServer
>     password=proxyPassword)
> TypeError: unexpected keyword argument: password
> 
> Any ideas on what could be causing this?

	Verify you have the latext python-xmlrpc package. The password
argument is a relatively recent addition to the python-xmlrpc package.
It needs python-xmlrpc 1.4 or higher.


Adrian





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]