[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: vmware woes again....



The Open Source method strikes again! I want to thank all
those who replied so quickly to my request for help.
Gene's fix was the one I tried and it worked great. I'm now
back in MS land working on work schedule spread sheets for
my boss. (What fun....)

Thanks all again. Steve.

(That new system disk of mine really hawls ass, it was
worth the vmware hassle..., and I can now play with
reiserfs, more fun!)

"Gene C." wrote:
> 
> On Thursday 08 March 2001 13:33, Stephen Adler wrote:
> > After doing what I swore I would never do at this
> > time, (install new system disk ultra scsi x15 segate cheeta
> > 160Mbytes/sec, yeow...) and upgrading the kernel to 2.4.2-0.1.19,
> > I broke vmware.... I know this is not the concern of redhat,
> > but when I try and compile the vmware drives, the network
> > driver fails with an unresolved symbol....
> >
> >
> > make: Entering directory `/tmp/vmware-config1/vmnet-only'
> > bridge.c: In function `VNetBridgeReceiveFromDev':
> > bridge.c:788: warning: implicit declaration of function `skb_datarefp'
> > make: Leaving directory `/tmp/vmware-config1/vmnet-only'
> > Unable to make a vmnet module that can be loaded in the running kernel:
> > /tmp/vmware-config1/vmnet.o: unresolved symbol skb_datarefp
> >
> > would anyone know what happend to skb_datarefp when going from
> > 2.4.1 to 2.4.2? I've got the code, I can modify the source. my
> > guess is that this is an easy fix....
> >
> >
> 
> OK, I checked the vmware newsgroups and there are a couple of patches for
> what appears to be this problem.  One of them seems to work for me.
> 
> The patch for vmware is attached.
> 
> First, untar the /usr/lib/vmware/modules/source/vmnet.tar tarball.  Then
> apply the patch.  Then rebuild the tarball and replace the original tarball.
> 
> running /usr/bin/vmware-config.pl now works.
> 
> Gene
> 
>   ------------------------------------------------------------------------
>                   Name: vmnet.patch
>    vmnet.patch    Type: text/x-c
>               Encoding: base64





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]