Debian and dmraid... is it possible to install?

Emiliano skywalk3r at
Fri Jul 22 13:40:17 UTC 2005

Alle 08:43, venerdì 22 luglio 2005, Albert Dengg ha scritto:
> On Thu, 21 Jul 2005 01:24:49 +0200
> hi
> well i don't know if it is possible with d-i, but doing a chroot install
> should be possible
> (you already seem to have a bootloader installed, so there should be no
> problems)
> like discribed here for example
> (ok, it is for woody, but that is just a matter of s/woody/sarge/)+
> (should be possible from gentoo to....)
> i have not tried it to set up a dmraid setup
> (i have not tried that at all-my only ataraid install used a 2.4
> kernel...)
> but it should work with some customizing i think

Thank you very much for those info.

Eventually, after other tries, I got this ("better") error:

mkinitrd: unkown DM device xx:xx (these where actual minor major numbers).
it seems it can't find something to cope with /dev/mapper/sil...

So I changed the beginning of the script to:

echo $1 $2
exit 0

and noticed it would create the file /boot/

I used the gentoo initrd (with dmraid) and copied where appropriate, also 
copied the modified mkinitrd on a floppy and copied it back on /usr/sbin "on 
the fly" just after kernel image installation.....

Installation of the base system then went on ok and concluded (initrd renamed to initrd.img-2... and complained about grub, but this was 
OK for the installer).

In the end I have a working system, BUT I can't login with a normal user 
account and X server... "/dev/null" permission denied, then chmod 
+666 /dev/null and still other errors...

I'll now try as you suggested: chroot into debian partiton and installation 
from there.


More information about the Ataraid-list mailing list