No subject

Anthony B ablakemore at
Sun Feb 6 04:19:52 UTC 2011

I have a problem i think/hope related to a hpa (host protected area) my original post is here

Anyway, it boils down to an old board of mine set a hpa to store a bios backup, not my choice, i liked it off but it was a default on setting so it would get enabled every time i reset cmos. That board died. I bought a new board and a new disk and forgot about hpa. I created a raid array with said old disk and new disk. Installed an m$ os on raid array. All worked well.

Needed to mount array under Linux, hit problem. That old disk wasn't detected as part of the array and on reboot wasn't detected as part of an array by the boards own raid manager but power cycling fixed it. I checked logs, etc and found nothing.

Now i dumped the last 3000 sectors of the offending disk and saw references to a bios manufacturer, the name and the chipset of old board. The cogs in my brain turned slightly and i thought 'hpa'. Got a low level disk utility and sure enough there was a hpa on the disk, right at the end. I just disabled it. Bad idea, the array is no longer detected by the on-board manager.

I booted back to Linux and my brain ticked once more, on other Linux systems i saw the boot console instead of it being all hidden away and i remember a few years ago i saw a message for another disk saying something about unlocking hpa. I grepped logs for hpa and found:

ata1.00: HPA unlocked: 976771055 -> 976773168, native 976773168

Nice, everything has fallen into place now. I know why my disk would only be detected as part of the array after power cycling and why dmraid wouldn't detect it but, my array is broken and i want ALL my bytes back. All i have to do is re-enable hpa at the right place to get the raid working again and tell the kernel at boot not to mess with hpa. But like i say MY BYTES AND I WANT THEM BACK.

My point is, could dmraid be aware of hpa's and adjust itself accordingly? If nothing else, just scream a great big error message about disabling hpa detection at kernel boot time but never remove the hpa completely? I would think a few of the problems where ata raid disks weren't being detected were caused by this.

Your thoughts please.


More information about the Ataraid-list mailing list