Dec PC and speakup

Deborah Norling debee at
Mon Jun 18 04:36:40 UTC 2007

A couple of years ago I asked about this on the speakup list. I got a
variety of responses, but most people had either never gotten their Dec PC
working, or it was working perfectly and they had never experienced my
Perhaps this list might have a subscriber with some troubleshooting ideas.
Mine is a Dec PC2, the second ISA card that digital designed.  It's quite a
bit smaller than the original Dec PC.
I've downloadded the dec_pc.tgz archive from the speakup site as the speakup
documentation for 2.0 suggests. Since I hadn't gotten this working before, I
this time compared it to the actual contents of the dec_pc subdirectory in
the speakup 2.0 source code. The binary files were identical.
The binary files are dtload, a Linux executable, along with  dtpc.dic,
kernel.sys, lts.exe, ph.exe,and cmd.exe. I can't remember if there was also
a user.exe, but anyway, these looked like the files that come with the
DecPC1 DOS drivers.
I read through the source, and though it isn't exactly filled with helpful
comments, it appears to be a simple replacement for the DOS dtload, and its
purpose is to load those other files in to the decPC card's onboard RAM.
Following the directions in the README and speakup documentation, I stashed
all these files in /usr/local/lib/dec_pc and fixed the permissions. I edited
the dec_pc.conf and change the line
to io=0x250, since my dip switches are set to use that I/o address and it
works with the DOS drivers on my machine using that address.
Next I tried running dtload and got the error:
    kernel already loaded.
I tried the -v and the -t but though it did enter test mode and let me type,
it didn't speak. The -v reported attempts to load the files, but concluded
with the familiar "kernel already loaded". 
I rebooted to my DOS partition , and then from DOS, loaded the Dec PC2
drivers as if I were going to use a DOS screen reader. They talked and I
tested by echoing some output to COM4.
Then using Loadlin from DOS I booted linux and tried the dtload again. It
still said
    kernel already loaded.
Next I replaced all the lts.exe, dtpc.dic, kernel.sys, ph.exe, cmd.exe and
user.exe files with their dec PC2 equivalents. In other words, I overwrote
the decPC1 files with the dec PC2 files. I also put user.exe in that
directory, since I'm sure the PC 2 needs it but not sure the PC1 needed it.
I then rebooted, straight in to linux, without DOS and tried running dtload
again. I still got the "kernel already loaded message. I double-checked that
all the files were listed in the correct order in the text file dec_pc.conf.
By "correct" I mean the order they are loaded by the DOS version of dtload. 
Still it said "kernel already loaded".
Last of all, now using the files from my decPC2 DOS drivers disk, I rebooted
to DOS. I first ran the DOS drivers and tested that the PC2 was talking. I
then booted from DOS in to Linux using loadlin and tried dtload -t again.
This time it still said "kernel already loaded" but it talked in test mode.
I repeated the tests and it appears that the DOS drivers need to be loaded
first. Or maybe the linux dtload isn't doing a darned thing with the DOS
drivers loaded. Anyway, if I boot straight to linux it doesn't talk ever,
but if I load DOS drivers first, it will talk but only in test mode.
Finally, I tried echoing the decpc keyword to the synth_name in /proc:
echo decpc >/proc/speakup/synth
as the documentation suggested and I also tried:
echo decpc >/proc/speakup/synth_name 
in case there was a typo in the speakup documentation. 
either way when I cat /proc/speakup/synth_name, it still says none. I used
ssh to control the machine so I wouldn't need a working synthesizer for
these tests.
I had set up lilo and loadlin to boot with the parameter speakup_synth=none
to be sure there was no confusion. But speakup never finds my dec pc2.
I can guess that there might be three causes for my problem:
1 -- I don't have a kernel with the decpc module. This is slackware 11.0's
stock speakup.s kernel. I am not experienced enough to tell whether the
decpc module is available or not. Maybe someone can help me figure out at
least whether the module is available.
2 -- Dtload was never supposed to work with DecPC2. No matter what I try, if
this is the problem, the dec pc2 isn't going to work with speakup. Will it
work with other access solutions like emacspeak or yasr?
3 -- The instructions left out a crucial step I still need to perform. I am
an intermediate level user, and there is much I still don't know how to do.
But I am good at following directions.
Any thoughts would be appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Blinux-list mailing list