Getting the Correct Terminal Behavior

Martin McCormick martin at
Fri Jan 15 16:10:27 UTC 2010

	After beginning to use speakup for almost 3 weeks, I am
truly impressed with how well it works but I am doing something
wrong when trying to use an RS-232 port to talk to another
system. I had been using ckermit which will work perfectly to
open the serial port and give you a good working communications
channel to the device in question. Ckermit, however, relies on
your existing terminal emulation which is a good Unix practice,
but something is wrong. The default login TERM value is Linux
which works correctly in the shell and when one uses ssh to
access a remote system. If I serial in to that same remote
system, output from even simple commands such as date is odd
sounding like it may have some double characters that should not
be there in it.

	I ran screen -t vt100 to start a shell then called
kermit and connected to the device. I also called kermit
directly from the shell and got the same behavior. The best way
to describe it is that it is almost right.

	I tried it on a serial install of FreeBSD and it worked
but badly. The output from the curses-based full-screen
installer was almost unintelligible.

	I do not hear a bunch of VT100 escape codes and the
cursor is always in the right place but it is rough to listen
to. If one uses the keypad Plus key, the screens are all proper
so I am getting terminal emulation. As soon as I end the serial
session, everything is good again.

	I also used screen to attach directly to the /dev/ttySx
serial port. This also had the same problem with the added issue
that I could never seem to get rid of the port binding after
ending the serial session.

	Any ideas as to what to do differently?
Martin McCormick

More information about the Blinux-list mailing list