fsck.ext3 reporting large file I cannot find

edmond rodriguez erodrig_97 at yahoo.com
Wed Apr 4 17:57:29 UTC 2007

I am checking a file system (ext3) as shown below.  It is actually a fresh file
system, as I had deleted all partitions and created an ext3 file system.  But
when I run the check with the verbose option, it says I have one large file. 
Am I missing something here, or is it odd that I cannot find this large file it
is reporting?  I reviewed some documentation on ext3 file systems, and
experimented with different sizes and formats, but finally decided to post
(after reviewing archives).  Is this "large file" just a private file used by
the file system itself, or maybe the journal?  It is a large drive (500GB), so
maybe a large file got generated which normally might appear smaller on a
smaller drive. 

I tried ls -sal and other flags with ls looking for the large file.  I also ran
dump2fs, although the output can be somewhat complex.

I included the beginning of the dump2efs output below my fsck.ext3 output.



[root at localhost sbin]# /sbin/fsck.ext3 -f -v -n /dev/sda1
e2fsck 1.35 (28-Feb-2004)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information

      11 inodes used (0%)
       1 non-contiguous inode (9.1%)
         # of inodes with ind/dind/tind blocks: 0/0/0
 1967476 blocks used (1%)
       0 bad blocks
       1 large file

       0 regular files
       2 directories
       0 character device files
       0 block device files
       0 fifos
       0 links
       0 symbolic links (0 fast symbolic links)
       0 sockets

[root at localhost sbin]# mount /mnt/lacie
[root at localhost sbin]# cd /mnt/lacie
[root at localhost lacie]# ls -sal
total 28
 4 drwxr-xr-x  3 root root  4096 Mar 21 16:57 .
 8 drwxr-xr-x  3 root root  4096 Mar 12 19:17 ..
16 drwx------  2 root root 16384 Mar 21 16:57 lost+found
[root at localhost lacie]# cd lost*
[root at localhost lost+found]# ls -sal
total 20
16 drwx------  2 root root 16384 Mar 21 16:57 .
 4 drwxr-xr-x  3 root root  4096 Mar 21 16:57 ..
[root at localhost lost+found]# cd ..
[root at localhost lacie]# df -h .
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda1             459G  201M  435G   1% /mnt/lacie
[root at localhost lacie]#

The above is showing a 1 percent usage.   When viewing in gparted, it
shows several gigbytes of storage getting used.


Filesystem volume name:   <none>
Last mounted on:          <not available>
Filesystem UUID:          340259f3-c529-4d44-b9c1-8a417ddb7046
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      has_journal resize_inode dir_index filetype
needs_recovery sparse_super large_file
Default mount options:    (none)
Filesystem state:         clean
Errors behavior:          Continue
Filesystem OS type:       Linux
Inode count:              61063168
Block count:              122098008
Reserved block count:     6104900
Free blocks:              120130532
Free inodes:              61063157
First block:              0
Block size:               4096
Fragment size:            4096
Reserved GDT blocks:      1024
Blocks per group:         32768
Fragments per group:      32768
Inodes per group:         16384
Inode blocks per group:   512
Filesystem created:       Wed Mar 21 16:54:23 2007
Last mount time:          Fri Mar 23 20:20:53 2007
Last write time:          Fri Mar 23 20:20:53 2007
Mount count:              6
Maximum mount count:      36
Last checked:             Fri Mar 23 19:20:18 2007
Check interval:           15552000 (6 months)
Next check after:         Wed Sep 19 19:20:18 2007
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:               128
Journal inode:            8
Default directory hash:   tea
Directory Hash Seed:      76883ff6-d60c-4ed7-8544-4edfe096f55a
Journal backup:           inode blocks

No need to miss a message. Get email on-the-go 
with Yahoo! Mail for Mobile. Get started.

More information about the Ext3-users mailing list