wipe freespace on ext3?

Eric Sandeen sandeen at redhat.com
Sat Apr 12 15:27:09 UTC 2008

defcon wrote:
> Hey all, I have failed at wiping my freespace on my hard drive, what I
> have done is:
> [dd] if=/dev/urandom of=bigfile
> and I also have tried sfill from the secure delete package from thc.
> I have successfully recovered all deleted files after wiping the hard
> drive with foremost, since this is a journaling filesystem is there
> any way around this, is anyone experienced in this and have tried to
> wipe/recover files on ext3?
> Thanks
> defcon

If you think journaling is the issue, tune2fs -O ^has_journal, mount it
as ext2, and run your wiper again.

However, in almost all cases I would not expect that you'll be able to
recover "all deleted files" from a properly wiped filesystem, even with
a journal.  (the exception might be something like only a few files
deleted, and journaled data mode, and a very smart recovery tool,
although I'd expect the wiper to wrap the log anyway, depending on how
it runs).


More information about the Ext3-users mailing list