problems with usb stick after suspend and wake up

Alan Stern stern at
Mon Sep 29 14:15:15 UTC 2014

On Mon, 29 Sep 2014, Norbert Preining wrote:

> Hi Alan,
> sorry for the journalctl output. I have now done the following:L
> * boot into 3.17-rc7
> * mount the usb stick (recovery completed)
> * unmount, mount, unmount - just to be sure all is fine
> * started usbmon capturing on bus 3
> * mount the usb stick
> * suspend to ram
> * wake up
> 	now the stick is "officially" mounted (/proc/mounts)
> * umount 
> 	error messages pop up
> * try to mount
> 	more error messages
> * capture dmesg output
> * stip usbmon
> The two files are available here:
> (size 21596)
> (size 216343)
> and
> (size 17883)
> (size 67734)
> Just a few more things:
> * usb persistency is turned on
> * I checked the stick with badblocks during creation of the fs

The first error occurred the first time the computer tried to write 
data to the stick following the resume.  Oddly enough, an earlier write 
before the suspend worked correctly.  But the real problem occurred 
when the computer asked the stick to provide the reason for the error.  
At that point the stick refused to answer.

There were several resets, and the write was retried after each reset.  
And each time the write failed, and the stick refused to answer when 
asked the reason for the failure.

There's no obvious cause for this problem.  It really looks like 
something is wrong with the USB stick.

Alan Stern

More information about the Ext3-users mailing list