[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpm database bug



(I tried to find a bug mailing list but failed)


While trying to:

rpm -i tetex-fonts-2.0.2-8.i386.rpm

I got the following error message:

rpmdb: page 1647: illegal page type or format
rpmdb: PANIC: Invalid argument
rpmdb: /var/lib/rpm/Packages: pgin failed for page 1647
rpmdb: fatal region error detected; run recovery
rpmdb: fatal region error detected; run recovery
rpmdb: db4 error(-30982) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: fatal region error detected; run recovery
rpmdb: db4 error(-30982) from dbcursor->c_close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: fatal region error detected; run recovery
rpmdb: db4 error(-30982) from db->cursor: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: fatal region error detected; run recovery
rpmdb: db4 error(-30982) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: fatal region error detected; run recovery
rpmdb: db4 error(-30982) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: fatal region error detected; run recovery
rpmdb: db4 error(-30982) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot get Providename index using db3 -  (-30982)
rpmdb: fatal region error detected; run recovery
rpmdb: db4 error(-30982) from db->cursor: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: fatal region error detected; run recovery
rpmdb: db4 error(-30982) from db->put: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: fatal region error detected; run recovery
rpmdb: db4 error(-30982) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: fatal region error detected; run recovery
rpmdb: db4 error(-30982) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery

Note that I'm running using:

> System-wide, you can disable the exec-shield functionality with:
>
> 	echo 0 > /proc/sys/kernel/exec-shield

as I'm trying to find a bug. I need to install latex and the rpm install
process failed.

I did:

  rpm --rebuilddb

Now rpm seems to work but the database doesn't remember anything.
If I do:

  rpm -i tetex-2.0.2-8-i386.rpm

then do:

  rpm -i tetex-dvips-2.0.2-8.i386.rpm

it complains that:
error: Failed dependencies:
  tetex = 2.0.2 is needed by tetex-dvips-2.0.2-8

running:

  rpm -i tetex-2.0.2-8-i386.rpm tetex-dvips-2.0.2-8.i386.rpm

seems to succeed.

Tim Daly
axiom tenkan org
daly idsi net


  
------- End of forwarded message -------




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]