add --enable-libsuffix=64

Neal Becker ndbecker2 at
Thu Jan 12 15:28:37 UTC 2006

Rex Dieter wrote:

> Neal Becker wrote:
>> I've been testing FC5T1, and as I'm building some kde packages, I seem to
>> need to add --enable-libsuffix=64.  Probably because X moved.
> Every libsuffix problem I've seen wrt kde apps had to do with qt, and
> was solved by defining QTINC/QTLIB, which is done now by qt-devel's
> /etc/profile.d/qt.(sh|csh)
> Perhaps if you could post more details, we could help more instead of
> merely speculating... (-:
> -- Rex

Sure.  I grabbed the latest krename-3.0.10 tar, and after minor editing to
krename.spec included in the tar (copyright->license) try build:

+ ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu
--target=x86_64-redhat-linux-gnu --program-prefix= --prefix=/usr
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com
--mandir=/usr/share/man --infodir=/usr/share/info
checking for X... libraries /usr/lib, headers .

Nope, that won't work!

If I add --enable-libsuffix=64:

checking for X... libraries /usr/lib64, headers .

This seems to happen on several kde packages I tried.  I believe it is
because of relocation of X from /usr/X11R6/lib64 to /usr/X11R6.  I think
kde packages had been fixed to look in /usr/X11R6/lib64, but now they would
all need to be fixed to look in /usr/lib64 for X libs?

More information about the fedora-devel-list mailing list