F12: NetworkManager-Firefox: Firefox is currently in offline mode and can't browse the Web

Terry Barnaby terry1 at beam.ltd.uk
Wed Dec 2 22:34:47 UTC 2009

On 12/02/2009 09:48 PM, Terry Barnaby wrote:
> On 12/02/2009 09:32 PM, Dan Williams wrote:
>> On Tue, 2009-12-01 at 10:24 +0000, Terry Barnaby wrote:
>>> On 12/01/2009 07:50 AM, Dan Williams wrote:
>>>> On Mon, 2009-11-30 at 19:52 +0000, Terry Barnaby wrote:
>>>>> On 11/30/2009 06:12 PM, Dan Williams wrote:
>>>>>> On Mon, 2009-11-30 at 09:55 +0000, Terry Barnaby wrote:
>>>>>>> On 11/29/2009 11:30 PM, Dan Williams wrote:
>>>>>>>> On Sat, 2009-11-28 at 09:10 +0000, Terry Barnaby wrote:
>>>>>>>>> On 11/28/2009 08:35 AM, Rakesh Pandit wrote:
>>>>>>>>>> 2009/11/28 Terry Barnaby wrote:
>>>>>>>>>>> If the NetworkManager service is running, but not managing
>>>>>>>>>>> the current
>>>>>>>>>>> network connection, then Firefox starts up in offline mode.
>>>>>>>>>>> Is this a bug in NetworkManager or Firefox ?
>>>>>>>>>> This is odd behaviour and needs to be fixed. I would suggest
>>>>>>>>>> open up a
>>>>>>>>>> bug against firefox. I know one can change
>>>>>>>>>> toolkit.networkmanager.disable preference, but it is a PITA
>>>>>>>>>> for our
>>>>>>>>>> users. One of use cases is: Sometime network manager does not
>>>>>>>>>> connect
>>>>>>>>>> me via my CDMA usb modem (in case signal is weak), but wvdial
>>>>>>>>>> does and
>>>>>>>>>> once I switch from NM to wvdial, my firefox gets to offline mode,
>>>>>>>>>> which I don't expect it to as I am connected.
>>>>>>>>> Ok, filed as: 542078
>>>>>>>> NetworkManager is intended to control the default internet
>>>>>>>> connection.
>>>>>>>> If NetworkManager cannot control the default internet
>>>>>>>> connection, then
>>>>>>>> you may not want to use NetworkManager.
>>>>>>>> In your case, you're using a mobile broadband device. The real
>>>>>>>> bug here
>>>>>>>> is that for whatever reason, NM/MM aren't connecting your modem,
>>>>>>>> and we
>>>>>>>> should follow up on that bug instead.
>>>>>>>> Dan
>>>>>>> I am not using a mobile broadband device. The network connection
>>>>>>> my systems
>>>>>> My mistake. I guess it was Rakesh Pandit who was using a CDMA 3G
>>>>>> connection.
>>>>>>> use is not just the Internet it is a local network LAN connection
>>>>>>> that also
>>>>>>> serves the internet. Most of my systems use a local network
>>>>>>> server which
>>>>>>> provides NIS, /home and /data using NFS and VPN etc. I normally
>>>>>>> use the
>>>>>>> service "network" to bring up wired or wireless networking for
>>>>>>> this. Fedora,
>>>>>>> by default, uses NetworkManager to manage all network devices
>>>>>>> though. I use
>>>>>>> the service "network" as, for some reason, the NetworkManager
>>>>>>> service is
>>>>>>> started after the netfs and other services are started. Is there
>>>>>>> a reason
>>>>>>> for this ??
>>>>>> No particular reason, in fact that looks like a bug. NM no longer
>>>>>> depends on HAL, but that dependency is still in the initscript, which
>>>>>> looks like it pushes NM later than netfs.
>>>>>> But in reality, you're looking for a dependency based initsystem
>>>>>> which
>>>>>> we don't quite yet have. There are already scripts that kick netfs to
>>>>>> mount stuff when NM brings the network up
>>>>>> (/etc/NetworkManager/dispatcher.d/05-netfs), so you get asynchronous
>>>>>> bootup *and* your mounts. The rest of the system, if it requires
>>>>>> something from the mounted directories, needs to be smart enough
>>>>>> to know
>>>>>> that.
>>>>>> If you need to, you can set NETWORKWAIT=yes in
>>>>>> /etc/sysconfig/network,
>>>>>> which causes the NetworkManager initscript to block until a network
>>>>>> connection is brought up, or 30 seconds have passed.
>>>>>>> I can obviously turn of the NetworkManager service, which I have
>>>>>>> done on the
>>>>>>> desktop systems. However, I also have a few Laptops that can
>>>>>>> roam. In F11 and
>>>>>>> before I have used the network and NetworkManager services. When
>>>>>>> the laptop
>>>>>>> boots away from home, the "network" service fails and I can then
>>>>>>> use the
>>>>>>> NetworkManager service to connect to whatever wireless network or
>>>>>>> G3 network is
>>>>>>> available.
>>>>>>> It does seem sensible to me that the "system" provides
>>>>>>> applications with info
>>>>>>> on if the network is up (not just the Internet). The
>>>>>>> NetworkManager service
>>>>>>> seems the place to do this and it looks like the applications are
>>>>>>> starting
>>>>>>> to use it for this purpose.
>>>>>>> So maybe a generic NM "isNetworkUp()" API call is called for ?
>>>>>> See the other mail; the problem with a generic isUp() is that it
>>>>>> simply
>>>>>> says hey, is there a connection? It doesn't provide enough
>>>>>> information
>>>>>> about the networking state of the system for anything to make an
>>>>>> intelligent decision about anything. It's a "hey I'm connected to
>>>>>> something" but there's no information about *what* you're
>>>>>> connected to;
>>>>>> whether it's a secure home network, whether it's a slow 3G network,
>>>>>> whether it's billed by the minute or the hour or unlimited, etc.
>>>>>> Dan
>>>>> Hi, Thanks for the info.
>>>>> I would have thought that a generic isUp() is good enough for the
>>>>> likes
>>>>> of Firefox and Pidgen though to decide if to start offline. Being
>>>>> connected to a
>>>>> Network is probably all you need, you may be accessing an Intranet
>>>>> as all
>>>>> my systems Firefox home pages do ...
>>>>> Anyway, following your email (And notes in Bugzilla) I thought I'd
>>>>> try and
>>>>> use NM properly for my config. However I have a problem, which may be
>>>>> a bug. I have turned off the Network services and turned on
>>>>> NetworkManger.
>>>>> I have two main network interfaces eth0 (wired) and eth1 (Wifi),
>>>>> both are
>>>>> set to be managed by NM and to start at boot. I have also added
>>>>> NETWORKWAIT=yes in /etc/sysconfig/network.
>>>>> When I boot with this the network (eth1 (eth0 is disconnected))
>>>>> does not
>>>>> come up at boot. There is a message stating a failure on the line
>>>>> where it is waiting for the network to come up. When I log in as a
>>>>> local user the network then comes up ...
>>>>> I also note that, before the user is logged in, I cannot start the
>>>>> network
>>>>> with "service network start" and the WiFi light is off. It looks like
>>>>> NM has done something like powered down my WiFi chip ?
>>>>> (Intel Corporation PRO/Wireless 2915ABG IBM Thinkpad R52)
>>>>> Another thing, I would need NETWORKWAIT=yes as I have ypbind enabled.
>>>>> Maybe ypbind should be modified to not start when the network is
>>>>> down and
>>>>> also added to /etc/NetworkManager/dispatcher.d ?
>>>> NM has two types of connection: system and user (see
>>>> http://live.gnome.org/NetworkManagerConfiguration ). NM treats ifcfg
>>>> files as system connections and thus they are available at boot time
>>>> and
>>>> before login. I had assumed that since your connection was working
>>>> correctly with the 'network' service that it was also a system
>>>> connection. What is the result of
>>>> 'ls /etc/sysconfig/network-scripts/ifcfg-*' and what are the contents
>>>> of /var/log/messages when the device is not correctly connected on
>>>> bootup?
>>>> Before logging in, can you also drop to a VT, log in, and run 'nm-tool'
>>>> for me?
>>>> THanks,
>>>> Dan
>>> Hi Dan,
>>> As far as I am aware my connections are "system" connections. I have
>>> configured
>>> the Network interfaces using the system-config-network tool. When I
>>> use the
>>> "network" service the eth1 wireless network comes up fine at boot.
>>> When I use
>>> NetworkManager the eth1 wireless network does not come up at boot.
>>> There is the
>>> error: "Waiting for network... [FAILED]"
>>> If the NetworkManger service is running (eth1 has not come up) and I run
>>> "service network start" the eth1 interface still does not come up. If
>>> I stop the NetworkManger service and again run "service network
>>> start" then
>>> the eth1 interface comes up ...
>>> The configuration files are:
>>> /etc/sysconfig/network-scripts/ifcfg-* files are there:
>>> /etc/sysconfig/network-scripts/ifcfg-eth0
>>> /etc/sysconfig/network-scripts/ifcfg-eth1
>>> /etc/sysconfig/network-scripts/ifcfg-lo
>>> /etc/sysconfig/network-scripts/ifcfg-Vodaphone
>>> /etc/sysconfig/network-scripts/ifcfg-eth1 is:
>>> # Intel Corporation PRO/Wireless 2915ABG [Calexico2] Network Connection
>>> DEVICE=eth1
>>> HWADDR=00:16:6F:8A:E1:95
>>> ONBOOT=yes
>>> BOOTPROTO=dhcp
>>> TYPE=Wireless
>>> USERCTL=yes
>>> PEERDNS=yes
>>> IPV6INIT=no
>>> MODE=Auto
>> ^^^^ This is the problem. "Auto" is not a valid mode.
>> Dec 1 09:59:05 think NetworkManager: ifcfg-rh: error: Invalid mode
>> 'auto' (not 'Ad-Hoc' or 'Managed')
>> you'll probably be seeing something on the console when running "ifup
>> eth1" like this:
>> Error for wireless request "Set Mode" (8B06) :
>> SET failed on device wlan0 ; Invalid argument.
>> Since all ifup-wireless does is send $MODE to iwconfig, and "auto" is
>> not a valid mode.
> The "MODE" was set up by system-config-network, it is from
> its list of possible options for Mode and I think was the
> default.
> If I run ifup the error you mention is not reported and the
> interface comes up fine.
> However, I do get the error:
> domainname: you must be root to change the domain name
> Which I assume is due to another F12 bug. Could this cause NM
> to abort the connection ?
I note that "domainname" is called from /etc/dhcp/dhclient.d/nis.sh.
At point of invocation $UID and $EUID are 0 ....

>> Dan
>>> RATE=auto
>>> ESSID=beamwifi
>>> Section of /var/log/messages attached.
>>> Output of nm-tool attached.
>>> nm-tool also outputs the error on stderr:
>>> ** (process:1492): WARNING **: error: failed to read connections from
>>> org.freedesktop.NetworkManagerUserSettings:
>>> The name org.freedesktop.NetworkManagerUserSettings was not provided
>>> by any
>>> .service files
>>> Cheers
>>> Terry
>>> --
>>> fedora-devel-list mailing list
>>> fedora-devel-list at redhat.com
>>> https://www.redhat.com/mailman/listinfo/fedora-devel-list

More information about the fedora-devel-list mailing list