F12: NetworkManager-Firefox: Firefox is currently in offline mode and can't browse the Web

Terry Barnaby terry1 at beam.ltd.uk
Thu Dec 3 08:49:13 UTC 2009

>> The "MODE" was set up by system-config-network, it is from
>> its list of possible options for Mode and I think was the
>> default.
>> If I run ifup the error you mention is not reported and the
>> interface comes up fine.
>> However, I do get the error:
>> domainname: you must be root to change the domain name
>> Which I assume is due to another F12 bug. Could this cause NM
>> to abort the connection ?
> I note that "domainname" is called from /etc/dhcp/dhclient.d/nis.sh.
> At point of invocation $UID and $EUID are 0 ....

I added a "sh" into /etc/dhcp/dhclient.d/nis.sh to have a look.
Here getuid() and geteuid() return 0. whoami returns "root".
But when I run "domainname kingnet" I get the error:
"domainname: you must be root to change the domain name"
Also "su" states "su: incorrect password" without even
prompting for one. What is happening here ?
The environment variables are set by dhcp and do not have
the usual user environment variables ....
Note that on this system, selinux is disabled.

More information about the fedora-devel-list mailing list