[Fedora-directory-users] Database recreation, automount and performance

Vsevolod (Simon) Ilyushchenko simonf at cshl.edu
Wed Jul 13 16:21:07 UTC 2005


I'm extremely glad FDS is now freely available and almost open-source. I 
have run into some issues when I started playing with it.

1. I've tried to port my OpenLDAP database to it and found that that 
there is no automount objectclass specified by default. The automount 
and automountInformation classes are defined in Fedora schema extensions
that come with the openldap RPM, so not having them in FDS is a little
weird. I had to define them myself.

2. After a failed import I deleted the database and tried to recreate 
it. I went first to Configuration/Data/New Root Suffix and specified the 
base DN and the database name. Then I went to Data/<Server name:389>/ 
New Root Object and tried to create the root entry, but got this error:

"Only the Directory Manager has the right to create the Root Entry. Log 
in as Directory Manager to be able to perform this operation. "

I've checked that the manager DN is specified correctly in 

I tried restarting the directory server, but that did not help. How do I 
reinitalize it?

3) Finally, the Java administration console is extremely slow. I'm 
running over an SSH connection, but my server is a 2.8 Ghz machine with 
512 Mb of RAM. I wonder what console performance other people experience.

Thanks - I'm looking forward to deploying FDS with Windows sync!

Simon (Vsevolod ILyushchenko)   simonf at cshl.edu

Terrorism is a tactic and so to declare war on terrorism
is equivalent to Roosevelt's declaring war on blitzkrieg.

Zbigniew Brzezinski, U.S. national security advisor, 1977-81

More information about the Fedora-directory-users mailing list