[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: netmon_applet



On Wed, 2005-02-23 at 16:29 +0000, Gavin Henry wrote:

>RPMS etc:
>
>http://www.demonseed.net/~jp/code/netmon_applet/rpm/

I'm just now writing the naming standards for rpm, and there are already
two "do not do XXX" items in your package. (Not your fault, I can't
write these standards fast enough to keep up with new packages)

- Don't use underscores in the rpm name. Use - as a delimiter.
- If it relies on another application to function (in this case, an
applet for gnome that requires the gnome panel), it should be named
according to the "%{parent}-%{child} syntax.

So, based on that, I would suggest that it be renamed to:

gnome-applet-netmon

Also, when you rename it, you'll want to add:

Provides: netmon_applet
Obsoletes: netmon_applet

That way, users of the old package will have a clean upgrade path.

Looking into the package, you don't need to be packaging ABOUT-NLS,
COPYING, or INSTALL, since they're all the generic docs. (Also, I'm not
sure why ABOUT-NLS is in there, since the applet doesn't seem to be
translated).

Take the 0.fdr out of the version tag, not necessary for Fedora Extras.

Besides all that, it looks good to me.

~spot
---
Tom "spot" Callaway: Red Hat Sales Engineer || GPG Fingerprint: 93054260
Fedora Extras Steering Committee Member (RPM Standards and Practices)
Aurora Linux Project Leader: http://auroralinux.org
Lemurs, llamas, and sparcs, oh my!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]