Problems installing Fedora Core 1 via NFS/Kickstart

Orion Poplawski orion at
Fri Nov 14 23:49:32 UTC 2003

I'm trying to install Fedora Core 1 by migrating my existing RH9 NFS 
kickstart install process.  I've tried pxeboot, the boot.iso image, and 
the yarrow-disc1-i386.iso image.  However, upon starting anaconda I get:

error 2 reading header: cpio: Bad magic
error 2 reading header: cpio: Bad magic

Running anaconda, the Fedora Core system installer - please wait...
Traceback (most recent call last):
   File "/usr/bin/anaconda", line 341, in ?
     import signal, traceback, string, isys, iutil, time

   File "/usr/lib/anaconda/", line 22, in ?
     from rhpl.log import log
ImportError: No module named rhpl.log
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
umounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0
	/proc/bus/usb done
	/proc done
	/dev/pts done
	/tmp/ramfs done
	/mnt/source done
you may safety reboot your system

The alt-F4 syslog screen has a bunch of the following:

<4>Error -3 while decompressing!

It seems like I have some corrupt files somewhere, but I've double 
checked the iso images (md5sums and cmp /dev/cdrom iso).  I have been 
concerned about appearing to have gotten some corrupt files from one of 
the rsync mirrors I've tried  (stanford or  ibiblio?).  Is there a way 
to verify the rpms I've downloaded?  Although it seems like if anything 
is corrupt, it's in the initrd.img on the boot media.

Orion Poplawski
System Administrator                   303-415-9701 x222
Colorado Research Associates/NWRA      FAX: 303-415-9702
3380 Mitchell Lane, Boulder CO 80301

More information about the fedora-list mailing list