mrtg/apache config question

Don dnrlinux at
Sun Nov 16 17:18:08 UTC 2003

I installed FC 1, and mrtg...
I created a separate userid (mrtg) where I keep the mrtg config file, and an
html directory where mrtg puts the files it creates.
So I have /home/mrtg/html directory with permissions 755 so everybody can
read it.
mrtg runs as a daemon as user mrtg... and that works fine, I see the files
get updated every few minutes...

Apache serves pages from /var/www/html
so I created a symbolic link called mrtg --> /home/mrtg/html

The idea being that if I go to http://localhost/mrtg then it will show me
the files.... but I get a 403 Forbidden error

Apache is configured to "follow symlinks", and in fact I created another
link in /var/www/html:
    ln -s ../mrtg mrtghelp

And when I go to http://localhost/mrtghelp I get the mrtg doc files
displayed properly... so "follow links" works

I thought it may have been because there's no index.html file in
/home/mrtg/html and things weren't set up to allow a directory listing....
so I tried looking at a specific file... same error; then I created the
index.html file ... same error.

What I can't figure out is where is this 403 error coming from?

>From root I also changed permission of /home/mrtg to 755 ... nope, still get
the 403 error

The documentation for mrtg just says the files have to be in a directory
"visible to apache".... but it doesn't discuss how that's done ....

Any suggestions?


       (. .)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the fedora-list mailing list